summaryrefslogtreecommitdiffstats
path: root/daemons/ipa-kdb/Makefile.am
diff options
context:
space:
mode:
authorSumit Bose <sbose@redhat.com>2015-05-20 18:31:19 +0200
committerTomas Babej <tbabej@redhat.com>2015-07-08 01:56:52 +0200
commit9d026ba824e8451d52d02c839793cfc2893204d7 (patch)
treedb71295bc31737929c5c7e9177ebf95d617cacc2 /daemons/ipa-kdb/Makefile.am
parent7b524e783515a16102aeffdb69fa9ed5fca07c1b (diff)
downloadfreeipa-9d026ba824e8451d52d02c839793cfc2893204d7.tar.gz
freeipa-9d026ba824e8451d52d02c839793cfc2893204d7.tar.xz
freeipa-9d026ba824e8451d52d02c839793cfc2893204d7.zip
ipa-kdb: convert test to cmocka
Reviewed-By: Tomas Babej <tbabej@redhat.com>
Diffstat (limited to 'daemons/ipa-kdb/Makefile.am')
-rw-r--r--daemons/ipa-kdb/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/daemons/ipa-kdb/Makefile.am b/daemons/ipa-kdb/Makefile.am
index 80747491f..a4ea366b0 100644
--- a/daemons/ipa-kdb/Makefile.am
+++ b/daemons/ipa-kdb/Makefile.am
@@ -55,7 +55,7 @@ ipadb_la_LIBADD = \
$(NSS_LIBS) \
$(NULL)
-if HAVE_CHECK
+if HAVE_CMOCKA
TESTS = ipa_kdb_tests
check_PROGRAMS = ipa_kdb_tests
endif
@@ -73,9 +73,9 @@ ipa_kdb_tests_SOURCES = \
ipa_kdb_audit_as.c \
$(KRB5_UTIL_SRCS) \
$(NULL)
-ipa_kdb_tests_CFLAGS = $(CHECK_CFLAGS)
+ipa_kdb_tests_CFLAGS = $(CMOCKA_CFLAGS)
ipa_kdb_tests_LDADD = \
- $(CHECK_LIBS) \
+ $(CMOCKA_LIBS) \
$(KRB5_LIBS) \
$(LDAP_LIBS) \
$(NDRPAC_LIBS) \