summaryrefslogtreecommitdiffstats
path: root/rust/rust-nu-plugin.spec
diff options
context:
space:
mode:
Diffstat (limited to 'rust/rust-nu-plugin.spec')
-rw-r--r--rust/rust-nu-plugin.spec69
1 files changed, 69 insertions, 0 deletions
diff --git a/rust/rust-nu-plugin.spec b/rust/rust-nu-plugin.spec
new file mode 100644
index 0000000..31a2712
--- /dev/null
+++ b/rust/rust-nu-plugin.spec
@@ -0,0 +1,69 @@
+# Generated by rust2rpm 20
+%bcond_without check
+%global debug_package %{nil}
+
+%global crate nu-plugin
+
+Name: rust-%{crate}
+Version: 0.42.0
+Release: %autorelease
+Summary: Nushell Plugin
+
+# Upstream license specification: MIT
+License: MIT
+URL: https://crates.io/crates/nu-plugin
+Source: %{crates_source}
+
+ExclusiveArch: %{rust_arches}
+
+BuildRequires: rust-packaging
+
+%global _description %{expand:
+Nushell Plugin.}
+
+%description %{_description}
+
+%package devel
+Summary: %{summary}
+BuildArch: noarch
+
+%description devel %{_description}
+
+This package contains library source intended for building other packages which
+use the "%{crate}" crate.
+
+%files devel
+%{cargo_registry}/%{crate}-%{version_no_tilde}/
+
+%package -n %{name}+default-devel
+Summary: %{summary}
+BuildArch: noarch
+
+%description -n %{name}+default-devel %{_description}
+
+This package contains library source intended for building other packages which
+use the "default" feature of the "%{crate}" crate.
+
+%files -n %{name}+default-devel
+%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
+
+%prep
+%autosetup -n %{crate}-%{version_no_tilde} -p1
+%cargo_prep
+
+%generate_buildrequires
+%cargo_generate_buildrequires
+
+%build
+%cargo_build
+
+%install
+%cargo_install
+
+%if %{with check}
+%check
+%cargo_test
+%endif
+
+%changelog
+%autochangelog