summaryrefslogtreecommitdiffstats
path: root/rust/rust-indenter.spec
diff options
context:
space:
mode:
Diffstat (limited to 'rust/rust-indenter.spec')
-rw-r--r--rust/rust-indenter.spec85
1 files changed, 85 insertions, 0 deletions
diff --git a/rust/rust-indenter.spec b/rust/rust-indenter.spec
new file mode 100644
index 0000000..610fbe4
--- /dev/null
+++ b/rust/rust-indenter.spec
@@ -0,0 +1,85 @@
+# Generated by rust2rpm 21
+%bcond_without check
+%global debug_package %{nil}
+
+%global crate indenter
+
+Name: rust-%{crate}
+Version: 0.3.3
+Release: 1%{?dist}
+Summary: Formatter wrapper that indents the text, designed for error display impls
+
+# Upstream license specification: MIT OR Apache-2.0
+License: MIT or ASL 2.0
+URL: https://crates.io/crates/indenter
+Source: %{crates_source}
+
+ExclusiveArch: %{rust_arches}
+
+BuildRequires: rust-packaging >= 21
+
+%global _description %{expand:
+Formatter wrapper that indents the text, designed for error display impls.}
+
+%description %{_description}
+
+%package devel
+Summary: %{summary}
+BuildArch: noarch
+
+%description devel %{_description}
+
+This package contains library source intended for building other packages which
+use the "%{crate}" crate.
+
+%files devel
+# FIXME: no license files detected
+%doc %{crate_instdir}/CHANGELOG.md
+%doc %{crate_instdir}/README.md
+%{crate_instdir}/
+
+%package -n %{name}+default-devel
+Summary: %{summary}
+BuildArch: noarch
+
+%description -n %{name}+default-devel %{_description}
+
+This package contains library source intended for building other packages which
+use the "default" feature of the "%{crate}" crate.
+
+%files -n %{name}+default-devel
+%ghost %{crate_instdir}/Cargo.toml
+
+%package -n %{name}+std-devel
+Summary: %{summary}
+BuildArch: noarch
+
+%description -n %{name}+std-devel %{_description}
+
+This package contains library source intended for building other packages which
+use the "std" feature of the "%{crate}" crate.
+
+%files -n %{name}+std-devel
+%ghost %{crate_instdir}/Cargo.toml
+
+%prep
+%autosetup -n %{crate}-%{version_no_tilde} -p1
+%cargo_prep
+
+%generate_buildrequires
+%cargo_generate_buildrequires
+
+%build
+%cargo_build
+
+%install
+%cargo_install
+
+%if %{with check}
+%check
+%cargo_test
+%endif
+
+%changelog
+* Sat Mar 26 2022 Michel Alexandre Salim <salimma@fedoraproject.org> - 0.3.3-1
+- Initial package