summaryrefslogtreecommitdiffstats
path: root/ocaml/ocaml-easy-format.spec
diff options
context:
space:
mode:
Diffstat (limited to 'ocaml/ocaml-easy-format.spec')
-rw-r--r--ocaml/ocaml-easy-format.spec101
1 files changed, 0 insertions, 101 deletions
diff --git a/ocaml/ocaml-easy-format.spec b/ocaml/ocaml-easy-format.spec
deleted file mode 100644
index 76957e8..0000000
--- a/ocaml/ocaml-easy-format.spec
+++ /dev/null
@@ -1,101 +0,0 @@
-%global opt %(test -x %{_bindir}/ocamlopt && echo 1 || echo 0)
-%if !%{opt}
-%global debug_package %{nil}
-%endif
-
-Name: ocaml-easy-format
-Version: 1.0.2
-Release: 2%{?dist}
-Summary: High-level and functional interface to the Format module
-
-License: BSD
-URL: http://mjambon.com/easy-format.html
-Source0: http://mjambon.com/releases/easy-format/easy-format-%{version}.tar.gz
-
-ExclusiveArch: %{ocaml_arches}
-
-BuildRequires: ocaml >= 3.10.0
-BuildRequires: ocaml-findlib
-BuildRequires: ocaml-ocamldoc
-
-%global libname %(echo %{name} | sed -e 's/^ocaml-//')
-
-%description
-This module offers a high-level and functional interface to the Format
-module of the OCaml standard library. It is a pretty-printing
-facility, i.e. it takes as input some code represented as a tree and
-formats this code into the most visually satisfying result, breaking
-and indenting lines of code where appropriate.
-
-Input data must be first modeled and converted into a tree using 3
-kinds of nodes:
-
- atoms
- lists
- labeled nodes
-
-Atoms represent any text that is guaranteed to be printed as-is. Lists
-can model any sequence of items such as arrays of data or lists of
-definitions that are labeled with something like "int main", "let x
-=" or "x:".
-
-
-%package devel
-Summary: Development files for %{name}
-Requires: %{name}%{?_isa} = %{version}-%{release}
-
-%description devel
-The %{name}-devel package contains libraries and signature files for
-developing applications that use %{name}.
-
-
-%prep
-%setup -q -n %{libname}-%{version}
-sed -i.add-debuginfo 's/ocamlopt/ocamlopt -g/;s/ocamlc \(-[co]\)/ocamlc -g \1/' Makefile
-
-
-%build
-%if %opt
-make %{?_smp_mflags}
-%else
-make %{?_smp_mflags} all
-%endif
-
-
-%install
-# These rules work if the library uses 'ocamlfind install' to install itself.
-export DESTDIR=$RPM_BUILD_ROOT
-export OCAMLFIND_DESTDIR=$RPM_BUILD_ROOT%{_libdir}/ocaml
-mkdir -p $OCAMLFIND_DESTDIR
-make install
-
-
-%check
-make test
-
-
-%files
-%doc LICENSE
-%{_libdir}/ocaml/%{libname}/
-%if %opt
-%exclude %{_libdir}/ocaml/*/*.cmx
-%exclude %{_libdir}/ocaml/*/*.o
-%endif
-%exclude %{_libdir}/ocaml/*/*.mli
-
-
-%files devel
-%doc LICENSE README.md Changes
-%if %opt
-%{_libdir}/ocaml/*/*.cmx
-%{_libdir}/ocaml/*/*.o
-%endif
-%{_libdir}/ocaml/*/*.mli
-
-
-%changelog
-* Tue Jan 21 2014 Michel Salim <salimma@fedoraproject.org> - 1.0.2-2
-- Incorporate review feedback
-
-* Mon Jan 20 2014 Michel Salim <salimma@fedoraproject.org> - 1.0.2-1
-- Initial package