summaryrefslogtreecommitdiffstats
path: root/rust/rust-miette-derive.spec
diff options
context:
space:
mode:
authorMichel Alexandre Salim <salimma@fedoraproject.org>2022-03-26 11:50:38 -0700
committerMichel Alexandre Salim <salimma@fedoraproject.org>2022-03-26 11:50:38 -0700
commitd36f959e943ed13fa2baecb101e8ceec5199403c (patch)
tree209e1c6641e137331b291b15a09dc89f73423880 /rust/rust-miette-derive.spec
parent1b54935dd006eba02c80f61df600ea5cf36d6529 (diff)
downloadspecs-d36f959e943ed13fa2baecb101e8ceec5199403c.tar.gz
specs-d36f959e943ed13fa2baecb101e8ceec5199403c.tar.xz
specs-d36f959e943ed13fa2baecb101e8ceec5199403c.zip
rust-nu-protocol dependencies:
- miette - indenter - miette-derive Signed-off-by: Michel Alexandre Salim <salimma@fedoraproject.org>
Diffstat (limited to 'rust/rust-miette-derive.spec')
-rw-r--r--rust/rust-miette-derive.spec71
1 files changed, 71 insertions, 0 deletions
diff --git a/rust/rust-miette-derive.spec b/rust/rust-miette-derive.spec
new file mode 100644
index 0000000..5f1b81f
--- /dev/null
+++ b/rust/rust-miette-derive.spec
@@ -0,0 +1,71 @@
+# Generated by rust2rpm 21
+%bcond_without check
+%global debug_package %{nil}
+
+%global crate miette-derive
+
+Name: rust-%{crate}
+Version: 4.2.1
+Release: 1%{?dist}
+Summary: Derive macros for miette
+
+# Upstream license specification: Apache-2.0
+License: ASL 2.0
+URL: https://crates.io/crates/miette-derive
+Source: %{crates_source}
+
+ExclusiveArch: %{rust_arches}
+
+BuildRequires: rust-packaging >= 21
+
+%global _description %{expand:
+Derive macros for miette. Like `thiserror` for Diagnostics.}
+
+%description %{_description}
+
+%package devel
+Summary: %{summary}
+BuildArch: noarch
+
+%description devel %{_description}
+
+This package contains library source intended for building other packages which
+use the "%{crate}" crate.
+
+%files devel
+%license %{crate_instdir}/LICENSE
+%{crate_instdir}/
+
+%package -n %{name}+default-devel
+Summary: %{summary}
+BuildArch: noarch
+
+%description -n %{name}+default-devel %{_description}
+
+This package contains library source intended for building other packages which
+use the "default" feature of the "%{crate}" crate.
+
+%files -n %{name}+default-devel
+%ghost %{crate_instdir}/Cargo.toml
+
+%prep
+%autosetup -n %{crate}-%{version_no_tilde} -p1
+%cargo_prep
+
+%generate_buildrequires
+%cargo_generate_buildrequires
+
+%build
+%cargo_build
+
+%install
+%cargo_install
+
+%if %{with check}
+%check
+%cargo_test
+%endif
+
+%changelog
+* Sat Mar 26 2022 Michel Alexandre Salim <salimma@fedoraproject.org> - 4.2.1-1
+- Initial package