summaryrefslogtreecommitdiffstats
path: root/rust/rust-common-path.spec
diff options
context:
space:
mode:
authorMichel Alexandre Salim <salimma@fedoraproject.org>2022-01-08 22:29:47 -0800
committerMichel Alexandre Salim <salimma@fedoraproject.org>2022-01-08 22:29:47 -0800
commita1c0ddb4394bd700ef055f64ac8e030de05671d0 (patch)
tree2595c1b8380d0574b29017dc0714702e22d20b3b /rust/rust-common-path.spec
parent914e1367fedee0820e6fc37b4b014c1ba19ee9f4 (diff)
downloadspecs-a1c0ddb4394bd700ef055f64ac8e030de05671d0.tar.gz
specs-a1c0ddb4394bd700ef055f64ac8e030de05671d0.tar.xz
specs-a1c0ddb4394bd700ef055f64ac8e030de05671d0.zip
+ rust
- nu-stream - nu-table - nu-data - common-path - sys-locale - cstr_core Signed-off-by: Michel Alexandre Salim <salimma@fedoraproject.org>
Diffstat (limited to 'rust/rust-common-path.spec')
-rw-r--r--rust/rust-common-path.spec71
1 files changed, 71 insertions, 0 deletions
diff --git a/rust/rust-common-path.spec b/rust/rust-common-path.spec
new file mode 100644
index 0000000..e0167b8
--- /dev/null
+++ b/rust/rust-common-path.spec
@@ -0,0 +1,71 @@
+# Generated by rust2rpm 20
+%bcond_without check
+%global debug_package %{nil}
+
+%global crate common-path
+
+Name: rust-%{crate}
+Version: 1.0.0
+Release: %autorelease
+Summary: Finds the common prefix between a set of paths
+
+# Upstream license specification: MIT/Apache-2.0
+License: MIT or ASL 2.0
+URL: https://crates.io/crates/common-path
+Source: %{crates_source}
+
+ExclusiveArch: %{rust_arches}
+
+BuildRequires: rust-packaging
+
+%global _description %{expand:
+Finds the common prefix between a set of paths.}
+
+%description %{_description}
+
+%package devel
+Summary: %{summary}
+BuildArch: noarch
+
+%description devel %{_description}
+
+This package contains library source intended for building other packages which
+use the "%{crate}" crate.
+
+%files devel
+%license LICENSE-APACHE LICENSE-MIT
+%doc README.adoc
+%{cargo_registry}/%{crate}-%{version_no_tilde}/
+
+%package -n %{name}+default-devel
+Summary: %{summary}
+BuildArch: noarch
+
+%description -n %{name}+default-devel %{_description}
+
+This package contains library source intended for building other packages which
+use the "default" feature of the "%{crate}" crate.
+
+%files -n %{name}+default-devel
+%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
+
+%prep
+%autosetup -n %{crate}-%{version_no_tilde} -p1
+%cargo_prep
+
+%generate_buildrequires
+%cargo_generate_buildrequires
+
+%build
+%cargo_build
+
+%install
+%cargo_install
+
+%if %{with check}
+%check
+%cargo_test
+%endif
+
+%changelog
+%autochangelog