summaryrefslogtreecommitdiffstats
path: root/admin/python-cliapp.spec
diff options
context:
space:
mode:
authorMichel Alexandre Salim <salimma@fedoraproject.org>2012-06-03 13:13:34 +0700
committerMichel Alexandre Salim <salimma@fedoraproject.org>2012-06-03 13:13:34 +0700
commitbcff82938a0f80858137aa9f84d1d4d9ac22bf36 (patch)
tree147a78eafcf0417c20c35aaf37a424720543595b /admin/python-cliapp.spec
parentd02269009c5f0402f120e8d42e6d291c1277cc24 (diff)
downloadspecs-bcff82938a0f80858137aa9f84d1d4d9ac22bf36.tar.gz
specs-bcff82938a0f80858137aa9f84d1d4d9ac22bf36.tar.xz
specs-bcff82938a0f80858137aa9f84d1d4d9ac22bf36.zip
Spec files for the Obnam backup tool
Diffstat (limited to 'admin/python-cliapp.spec')
-rw-r--r--admin/python-cliapp.spec57
1 files changed, 57 insertions, 0 deletions
diff --git a/admin/python-cliapp.spec b/admin/python-cliapp.spec
new file mode 100644
index 0000000..680a9fb
--- /dev/null
+++ b/admin/python-cliapp.spec
@@ -0,0 +1,57 @@
+%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")}
+
+%global pkgname cliapp
+
+Name: python-%{pkgname}
+Version: 0.29
+Release: 1%{?dist}
+Summary: Python framework for Unix command line programs
+
+License: GPLv2+
+URL: http://liw.fi/%{pkgname}/
+Source0: http://code.liw.fi/debian/pool/main/p/%{name}/%{name}_%{version}.orig.tar.gz
+
+BuildArch: noarch
+BuildRequires: python-sphinx
+
+%description
+cliapp is a Python framework for Unix-like command line programs. It
+contains the typical stuff such programs need to do, such as parsing
+the command line for options, and iterating over input files.
+
+
+%package doc
+Summary: Documentation for %{pkgname}
+Requires: %{name} = %{version}-%{release}
+
+%description doc
+This package contains the documentation for %{pkgname}, a Python
+framework for Unix command line programs.
+
+
+%prep
+%setup -q -n %{pkgname}-%{version}
+
+
+%build
+%{__python} setup.py build
+# Build documentation
+make -C doc html
+
+
+%install
+%{__python} setup.py install -O1 --skip-build --root %{buildroot}
+
+
+%files
+%doc COPYING NEWS README
+%{_mandir}/man5/cliapp.5*
+%{python_sitelib}/*
+
+%files doc
+%doc doc/_build/html/*
+
+
+%changelog
+* Sun Jun 3 2012 Michel Salim <salimma@fedoraproject.org> - 0.29-1
+- Initial package