summaryrefslogtreecommitdiffstats
path: root/yum-presto/setup.py
diff options
context:
space:
mode:
authorJonathan Dieter <jdieter@gmail.com>2008-04-07 16:40:03 +0300
committerJonathan Dieter <jdieter@gmail.com>2008-04-07 16:40:03 +0300
commitb9156e0b55ebe94d243083c51d6819d6598de549 (patch)
tree323e4e48c9c70626c7e8b2ca30b07db6d73e2095 /yum-presto/setup.py
parent7e265d284e352de7eb924b8883a452bb75bcb1bc (diff)
downloadpresto-b9156e0b55ebe94d243083c51d6819d6598de549.tar.gz
presto-b9156e0b55ebe94d243083c51d6819d6598de549.tar.xz
presto-b9156e0b55ebe94d243083c51d6819d6598de549.zip
Use setuptools for installation
Signed-off-by: Jonathan Dieter <jdieter@gmail.com>
Diffstat (limited to 'yum-presto/setup.py')
-rw-r--r--yum-presto/setup.py23
1 files changed, 23 insertions, 0 deletions
diff --git a/yum-presto/setup.py b/yum-presto/setup.py
new file mode 100644
index 0000000..504d62c
--- /dev/null
+++ b/yum-presto/setup.py
@@ -0,0 +1,23 @@
+#!/usr/bin/env python
+"""
+Build script for yum-presto.
+"""
+from setuptools import setup, find_packages
+
+setup (name = "yum-presto",
+ version = '0.4.4',
+ packages = find_packages(),
+ description = "Utilizes the work done on deltarpm to provide faster, smaller size downloads to Fedora users.",
+ author = 'Jonathan Dieter',
+ author_email = 'jdieter@gmail.com',
+ license = 'GPLv2+',
+ platforms=["Linux"],
+
+ data_files=[('/usr/lib/yum-plugins/', ['presto.py']),
+ ('/etc/yum/pluginconf.d/', ['presto.conf'])],
+
+ classifiers=['License :: OSI Approved :: GNU General Public License (GPL)',
+ 'Operating System :: Unix',
+ 'Programming Language :: Python',
+ ],
+)