summaryrefslogtreecommitdiffstats
path: root/src/splash-plugins/text/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/splash-plugins/text/Makefile.am')
-rw-r--r--src/splash-plugins/text/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/src/splash-plugins/text/Makefile.am b/src/splash-plugins/text/Makefile.am
new file mode 100644
index 0000000..0a0552a
--- /dev/null
+++ b/src/splash-plugins/text/Makefile.am
@@ -0,0 +1,16 @@
+INCLUDES = -I$(top_srcdir) \
+ -I$(srcdir)/../../libply \
+ -I$(srcdir)/../.. \
+ -I$(srcdir)/.. \
+ -I$(srcdir)
+
+plugindir = $(libdir)/plymouth
+plugin_LTLIBRARIES = text.la
+
+text_la_CFLAGS = $(PLYMOUTH_CFLAGS)
+text_la_LDFLAGS = -module -avoid-version -export-dynamic
+text_la_LIBADD = $(PLYMOUTH_LIBS) ../../libply/libply.la
+text_la_SOURCES = $(srcdir)/../../ply-boot-splash-plugin.h \
+ $(srcdir)/text.c
+
+MAINTAINERCLEANFILES = Makefile.in