summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRay Strode <rstrode@redhat.com>2007-06-06 18:13:17 -0400
committerRay Strode <rstrode@redhat.com>2007-06-06 18:13:17 -0400
commitb157f818ac219a1a4a60619250b521d430576e83 (patch)
tree012f7555b793a2f3d5910d2080f8fdfaeaf867c3 /configure.ac
parent177a24020be55bfa9716cb6ebbfd018cfdf46416 (diff)
downloadplymouth-b157f818ac219a1a4a60619250b521d430576e83.tar.gz
plymouth-b157f818ac219a1a4a60619250b521d430576e83.tar.xz
plymouth-b157f818ac219a1a4a60619250b521d430576e83.zip
split the common code off into libply and move things to separate directories
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 8 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 5281c6d..57b81ec 100644
--- a/configure.ac
+++ b/configure.ac
@@ -32,14 +32,20 @@ PKG_CHECK_MODULES(IMAGE, [libpng >= 1.2.16 ])
AC_SUBST(IMAGE_CFLAGS)
AC_SUBST(IMAGE_LIBS)
-PLYMOUTH_CFLAGS=""
-PLYMOUTH_LIBS="-lm -ldl"
+PLYMOUTH_CFLAGS="$IMAGE_CFLAGS"
+PLYMOUTH_LIBS="-lm -ldl $IMAGE_LIBS"
AC_SUBST(PLYMOUTH_CFLAGS)
AC_SUBST(PLYMOUTH_LIBS)
AC_OUTPUT([Makefile
+ src/libply/Makefile
+ src/splash-plugins/Makefile
src/Makefile
+ src/rhgb-client/Makefile
src/tests/Makefile
+ src/libply/tests/Makefile
+ src/rhgb-client/tests/Makefile
+ src/splash-plugins/tests/Makefile
po/Makefile.in
])