summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRay Strode <rstrode@redhat.com>2008-05-30 00:21:05 -0400
committerRay Strode <rstrode@redhat.com>2008-05-30 00:21:05 -0400
commit4f635e04a66ec3c9f96edf662878204c2cb60e34 (patch)
treedeba0534ad8754fcd47f23d08047bc0c5cfa0cbb /configure.ac
parent5caee621a217e5693d89dd11a67943600e34e6c3 (diff)
downloadplymouth-4f635e04a66ec3c9f96edf662878204c2cb60e34.tar.gz
plymouth-4f635e04a66ec3c9f96edf662878204c2cb60e34.tar.xz
plymouth-4f635e04a66ec3c9f96edf662878204c2cb60e34.zip
Conditionalize tests with configure option
We do this so we can disable them from distcheck, but still build them easily when not doing distcheck.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7359367..495821b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -48,6 +48,10 @@ if test x$enable_tracing = xyes; then
AC_DEFINE(PLY_ENABLE_TRACING, 1, [Build in verbose debug tracing spew])
fi
+AC_ARG_ENABLE(tests, AS_HELP_STRING([--enable-tests],[build tests]),enable_tests=$enableval,enable_tests=yes)
+
+AM_CONDITIONAL(ENABLE_TESTS, [test "$enable_tests" = yes])
+
AC_ARG_WITH(boot-entry, AS_HELP_STRING([--with-boot-entry],[create initrd and grub entry]),with_boot_entry=$withval,with_boot_entry=yes)
AM_CONDITIONAL(ADD_BOOT_ENTRY, [test "$with_boot_entry" = yes])