summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRay Strode <rstrode@redhat.com>2008-05-29 16:54:00 -0400
committerRay Strode <rstrode@redhat.com>2008-05-29 16:54:00 -0400
commit3f91989cf323851d741b736fdca2560756800bb5 (patch)
tree49c5e0d42339fa4614630ec4ca27f7077ea22f23 /configure.ac
parent6226cd1119f10453111e11f560027719ea3831a5 (diff)
downloadplymouth-3f91989cf323851d741b736fdca2560756800bb5.tar.gz
plymouth-3f91989cf323851d741b736fdca2560756800bb5.tar.xz
plymouth-3f91989cf323851d741b736fdca2560756800bb5.zip
Allow distro/system builder to specify path to logo
Previously we've just hard coded the location to the fedora logo. Now it's a configure time flag. We also have a configure time flag for a background color that goes with the logo, but none of the splash plugins make use of it yet.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b86f35a..d435f9f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -48,6 +48,12 @@ if test x$enable_tracing = xyes; then
AC_DEFINE(PLY_ENABLE_TRACING, 1, [Build in verbose debug tracing spew])
fi
+AC_ARG_WITH(logo, AC_HELP_STRING([--with-logo], [logo used by boot splash plugins]),logofile=${withval},logofile=$datadir/pixmaps/system-logo-white.png)
+AC_SUBST(logofile)
+
+AC_ARG_WITH(background-color, AC_HELP_STRING([--with-background-color], [background color used by boot splash plugins]),background_color=${withval},background_color=0x005391)
+AC_SUBST(background_color)
+
AC_OUTPUT([Makefile
src/libply/Makefile
src/splash-plugins/Makefile