summaryrefslogtreecommitdiffstats
path: root/cross-binutils.spec
diff options
context:
space:
mode:
Diffstat (limited to 'cross-binutils.spec')
-rw-r--r--cross-binutils.spec60
1 files changed, 30 insertions, 30 deletions
diff --git a/cross-binutils.spec b/cross-binutils.spec
index ae05638..eb5269d 100644
--- a/cross-binutils.spec
+++ b/cross-binutils.spec
@@ -19,7 +19,8 @@
%define build_powerpc64 %{build_all}
%define build_s390x %{build_all}
%define build_score %{build_all}
-%define build_sh4 %{build_all}
+%define build_sh %{build_all}
+%define build_sh64 %{build_all}
%define build_sparc64 %{build_all}
%define build_tile %{build_all}
%define build_x86_64 %{build_all}
@@ -31,11 +32,8 @@
%define build_mips 0
%define build_powerpc 0
%define build_s390 0
-%define build_sh 0
%define build_sparc 0
-
-# do we want this?
-%define build_sh64 0
+%define build_sh4 0
# not available in binutils-2.22
%define build_hexagon 0
@@ -43,13 +41,13 @@
Summary: A GNU collection of cross-compilation binary utilities
Name: cross-binutils
-Version: 2.22.52.0.1
-Release: 8.1%{?dist}
+Version: 2.22.52.0.3
+Release: 1%{?dist}
License: GPLv3+
Group: Development/Tools
URL: http://sources.redhat.com/binutils
-Source: ftp://ftp.kernel.org/pub/linux/devel/binutils/binutils-%{version}.tar.bz2
+Source: ftp://ftp.kernel.org/pub/linux/devel/binutils/binutils-%{version}.tar.xz
# The ftp.kernel.org/pub/linux/devel/binutils/ page is (temporarily) unavailable
# so we use the GNU site instead.
# Source: http://ftp.gnu.org/gnu/binutils/binutils-%{version}.tar.bz2
@@ -61,19 +59,10 @@ Patch04: binutils-2.20.51.0.2-version.patch
Patch05: binutils-2.20.51.0.2-set-long-long.patch
Patch06: binutils-2.20.51.0.10-copy-osabi.patch
Patch07: binutils-2.20.51.0.10-sec-merge-emit.patch
-# Upstream http://sourceware.org/git/?p=binutils.git;a=commitdiff;h=f5edd1ac0e79c0356c6a1e2beffcadc0c532be98
-# Fixes RH #788107
-Patch08: binutils-2.22.52.0.1-weakdef.patch
-# From upstream, fixes ld/13621 bug 'dangling global hidden symbol in symtab'
-Patch09: binutils-2.22.52.0.1-ld-13621.patch
-# From upstream
-Patch10: binutils-rh797752.patch
# Enable -zrelro by default: BZ #621983
-Patch11: binutils-2.22.52.0.1-relro-on-by-default.patch
-# From upstream
-Patch12: binutils-2.22.52.0.1-x86_64-hidden-ifunc.patch
-# From upstream
-Patch13: binutils-2.22.52.0.1-tsx.patch
+Patch08: binutils-2.22.52.0.1-relro-on-by-default.patch
+# Local patch - export demangle.h with the binutils-devel rpm.
+Patch09: binutils-2.22.52.0.1-export-demangle.h.patch
Buildroot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
BuildRequires: texinfo >= 4.0, gettext, flex, bison, zlib-devel
@@ -174,14 +163,10 @@ cd %{srcdir}
%patch05 -p0 -b .set-long-long~
%patch06 -p0 -b .copy-osabi~
%patch07 -p0 -b .sec-merge-emit~
-%patch08 -p1 -b .weakdef~
-%patch09 -p1 -b .ld-13621~
-%patch10 -p1 -b .cxxfilt-docs~
-%if 0%{?fedora} >= 18
-%patch11 -p0 -b .relro~
+%if 0%{?fedora} >= 18 || 0%{?rhel} >= 7
+%patch08 -p0 -b .relro~
%endif
-%patch12 -p0 -b .x86_64-hidden-ifunc~
-%patch13 -p0 -b .tsx~
+%patch09 -p0 -b .export-demangle-h~
# We cannot run autotools as there is an exact requirement of autoconf-2.59.
@@ -288,7 +273,7 @@ function config_target () {
m68knommu-*) target=m68k-linux;;
openrisc-*) target=openrisc-elf;;
score-*) target=score-elf;;
- sh64-*) target=sh64-elf;;
+ sh64-*) target=sh64-linux;;
tile-*) target=tilegx-linux;;
v850-*) target=v850e-linux;;
*) target=$arch;;
@@ -324,7 +309,7 @@ function config_target () {
esac
case $target in sh64*)
- CARGS="$CARGS --enable-targets=sh-linux"
+ CARGS="$CARGS --enable-targets=sh64-linux,sh-elf,sh-linux,sh4-linux"
;;
esac
@@ -416,14 +401,22 @@ function install_bin () {
for target in `cat target.list`
do
+ echo "=== INSTALL target $target ==="
install_bin $target
+
+# if [ $target = sh64-linux-gnu ]
+# then
+# ln -s %{auxbin_prefix}/sh64-elf %{buildroot}%{auxbin_prefix}/sh64-linux
+# fi
done
+echo "=== INSTALL man targets ==="
make install-man1 -C cross-binutils/binutils/doc DESTDIR=%{buildroot}
make install-man1 -C cross-binutils/gas/doc DESTDIR=%{buildroot}
make install-man1 -C cross-binutils/ld DESTDIR=%{buildroot}
make install-man1 -C cross-binutils/gprof DESTDIR=%{buildroot}
+echo "=== INSTALL po targets ==="
make install -C cross-binutils/binutils/po DESTDIR=%{buildroot}
make install -C cross-binutils/gas/po DESTDIR=%{buildroot}
make install -C cross-binutils/ld/po DESTDIR=%{buildroot}
@@ -432,13 +425,16 @@ make install -C cross-binutils/bfd/po DESTDIR=%{buildroot}
make install -C cross-binutils/opcodes/po DESTDIR=%{buildroot}
# For cross-binutils we drop the documentation.
+echo "=== REMOVE documentation ==="
rm -rf %{buildroot}%{_infodir}
rm -f %{buildroot}%{_infodir}/dir
+echo "=== REMOVE libraries and scripts ==="
rm -rf %{buildroot}%{_libdir}/libiberty.a
rm -rf %{buildroot}%{auxbin_prefix}/*/lib/ldscripts
-rmdir %{buildroot}%{auxbin_prefix}/*/lib
+rmdir %{buildroot}%{auxbin_prefix}/*/lib || :
+echo "=== BUILD file lists ==="
function build_file_list () {
arch=$1
cpu=${arch%%%%-*}
@@ -471,6 +467,7 @@ done
# All the installed manual pages and translation files for each program are the
# same, so symlink them to the core package
+echo "=== CROSSLINK man pages ==="
cd %{buildroot}%{_mandir}/man1
for i in cross-*.1*
do
@@ -573,6 +570,9 @@ rm -rf %{buildroot}
%do_files xtensa-linux-gnu %{build_xtensa}
%changelog
+* Wed May 30 2012 David Howells <dhowells@redhat.com> - 2.22.52.0.3-1
+- Update to binutils-2.22.52.0.3.
+
* Thu Mar 22 2012 David Howells <dhowells@redhat.com> - 2.22.52.0.1-8.1
- Initial import of cross-binutils [BZ 761619].