summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRich Megginson <rmeggins@redhat.com>2007-06-08 20:36:53 +0000
committerRich Megginson <rmeggins@redhat.com>2007-06-08 20:36:53 +0000
commitd9b8787008e72e696b2b92f20e18b4c3f5f0a38c (patch)
tree3fc399b0047f15c994515c4a5e3470512f747c25 /configure.ac
parent7f686305a98a4289f4ebb3f62441523950352280 (diff)
downloadds-d9b8787008e72e696b2b92f20e18b4c3f5f0a38c.tar.gz
ds-d9b8787008e72e696b2b92f20e18b4c3f5f0a38c.tar.xz
ds-d9b8787008e72e696b2b92f20e18b4c3f5f0a38c.zip
Resolves: bug 237356
Description: Move DS Admin Code into Admin Server Fix Description: The Resource class needs to support more than 1 resource file e.g. for ds-base and ds-admin. The property dir should be under $datadir. Property files are data files, not really config files. Added a shared_lib_suffix token Fixed some wording errors in the resource file. Platforms tested: RHEL4 Flag Day: no Doc impact: No new doc impact from previous commits for this bug.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 0719313c..5d6ab021 100644
--- a/configure.ac
+++ b/configure.ac
@@ -186,8 +186,8 @@ fi
# Shared paths for all layouts
# relative to sysconfdir
configdir=/$PACKAGE_NAME/config
-# relative to sysconfdir
-propertydir=/$PACKAGE_NAME/property
+# location of property/resource files, relative to datadir
+propertydir=/$PACKAGE_NAME/properties
# relative to sysconfdir
schemadir=/$PACKAGE_NAME/schema
# relative to libdir
@@ -223,6 +223,7 @@ AC_SUBST(instconfigdir)
# cygnus, mingw, or the like and using cmd.exe as the shell
AM_CONDITIONAL([WINNT], false)
+shared_lib_suffix=.so
# Deal with platform dependent defines
# relative to sysconfdir
initdir=/rc.d
@@ -260,6 +261,7 @@ case $host in
AC_DEFINE([OS_hpux], [1], [OS HP-UX])
AC_DEFINE([_POSIX_C_SOURCE], [199506L], [POSIX revision])
AC_DEFINE([_HPUX_SOURCE], [1], [Source namespace])
+ shared_lib_suffix=.sl
platform="hpux"
;;
sparc-sun-solaris*)
@@ -295,6 +297,7 @@ dnl Cstd and Crun are required to link any C++ related code
;;
esac
AC_SUBST(initdir)
+AC_SUBST(shared_lib_suffix)
AM_CONDITIONAL(HPUX,test "$platform" = "hpux")
AM_CONDITIONAL(SOLARIS,test "$platform" = "solaris")