summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRich Megginson <rmeggins@redhat.com>2007-08-02 14:39:01 +0000
committerRich Megginson <rmeggins@redhat.com>2007-08-02 14:39:01 +0000
commitd7531c68d34d83c17c0d1996fec6d6a0ebfc0e4b (patch)
treed9dc41736d47540967b5523a96d6a0eed9f6b379 /configure.ac
parent2ebeaf1fbbba60e8ed0040bb904c1bb858a876c3 (diff)
downloadds-d7531c68d34d83c17c0d1996fec6d6a0ebfc0e4b.tar.gz
ds-d7531c68d34d83c17c0d1996fec6d6a0ebfc0e4b.tar.xz
ds-d7531c68d34d83c17c0d1996fec6d6a0ebfc0e4b.zip
Resolves: bug 250535
Bug Description: improve perldap script execution ability on bundled platforms Reviewed by: nkinder (Thanks!) Fix Description: Most platforms will just use perl from PATH. However, on Solaris and HP-UX, we have to use special 64 bit versions to execute perldap, since perldap is 64 bit on those platforms. Also, if bundling all of the dependent components into the single package, we need to make sure the perl library path is set correctly to find perldap. The last step will be to build our version of perldap on the bundled platforms to use rpath to point to the correct runtime library location. Platforms tested: RHEL4, HP-UX 11.23 IPF 64 bit Flag Day: no Doc impact: no
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b93155a5..07db323b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -238,6 +238,14 @@ AM_CONDITIONAL([WINNT], false)
# Deal with platform dependent defines
# relative to sysconfdir
initdir=/rc.d
+# on most platforms, we will just use perl from PATH
+# On some platforms, we cannot. Why not just use any old
+# perl? Because of perldap. We use a perldap that is
+# compiled to either 32bit or 64bit, so we must use a native
+# perl binary compiled with the same bitsize. On Solaris
+# and HP-UX, /usr/bin/perl is 32 bit, so we cannot use
+# those with our 64 bit compiled product.
+perlexec='/usr/bin/env perl'
case $host in
*-*-linux*)
AC_DEFINE([XP_UNIX], [1], [UNIX])
@@ -260,6 +268,8 @@ case $host in
AC_DEFINE([OS_hpux], [1], [OS HP-UX])
AC_DEFINE([_POSIX_C_SOURCE], [199506L], [POSIX revision])
AC_DEFINE([_HPUX_SOURCE], [1], [Source namespace])
+ # assume 64 bit
+ perlexec='/opt/perl_64/bin/perl'
platform="hpux"
;;
hppa*-hp-hpux*)
@@ -272,6 +282,8 @@ case $host in
AC_DEFINE([OS_hpux], [1], [OS HP-UX])
AC_DEFINE([_POSIX_C_SOURCE], [199506L], [POSIX revision])
AC_DEFINE([_HPUX_SOURCE], [1], [Source namespace])
+ # assume 64 bit
+ perlexec='/opt/perl_64/bin/perl'
platform="hpux"
;;
sparc-sun-solaris*)
@@ -299,6 +311,8 @@ dnl Cstd and Crun are required to link any C++ related code
LIBCRUN=-lCrun
AC_SUBST([LIBCRUN], [$LIBCRUN])
platform="solaris"
+ # assume 64 bit
+ perlexec='/opt/perl5x/bin/perl'
# relative to sysconfdir
initdir=/init.d
;;
@@ -307,6 +321,7 @@ dnl Cstd and Crun are required to link any C++ related code
;;
esac
AC_SUBST(initdir)
+AC_SUBST(perlexec)
AM_CONDITIONAL(HPUX,test "$platform" = "hpux")
AM_CONDITIONAL(SOLARIS,test "$platform" = "solaris")