summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRich Megginson <rmeggins@redhat.com>2007-06-19 18:24:58 +0000
committerRich Megginson <rmeggins@redhat.com>2007-06-19 18:24:58 +0000
commit72da2df3bae21741217e3175e020cdc3b83ac172 (patch)
tree4e12d324257ca8cfe4ba39ceb4337adfe0df588e /configure.ac
parent0046d389d23bd217e3109949064c33de07dbc017 (diff)
downloadds-72da2df3bae21741217e3175e020cdc3b83ac172.tar.gz
ds-72da2df3bae21741217e3175e020cdc3b83ac172.tar.xz
ds-72da2df3bae21741217e3175e020cdc3b83ac172.zip
Resolves: bug 237356
Description: Move DS Admin Code into Admin Server - ldif templates, pwdhash Reviewed by: nhosoi (Thanks!) Fix Description: These changes are primarily to allow the admin server setup to run completely in perl with no more setuputil code. 1) Added LDIF templates for DS config. template-dse.ldif is the core minimal directory server configuration. Values can be replaced with parameters in the same style as used with register_server.pl - %token%. For the plugin entries, the plugin shared library name is now just a name. There is no more full path. The code in dynalib.c handles this case by using the compiled in PLUGINDIR. The NSPR function PR_GetLibraryName knows the correct shared lib suffix for the platform. All of this allows us to do 2). 2) Added ability to run pwdhash with no server configuration. If no configuration is given, it uses the template-dse.ldif above. And instead of having to worry about where the plugins are installed and the shared lib suffix, it just depends on the above changes. This allows us to generate password hashes during setup before the directory server instance is created, and also to keep clear text password usage to a minimum. 3) Added defaultuser and defaultgroup. 4) Added support for continuation lines in Inf files. 5) All user visible messages during setup should be localizable Platforms tested: RHEL4 Flag Day: Yes, autotool file changes. Doc impact: Yes, along with the previous fixes for this bug.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 7 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index c53241de..69574876 100644
--- a/configure.ac
+++ b/configure.ac
@@ -197,6 +197,10 @@ schemadir=/$PACKAGE_NAME/schema
# relative to libdir
perldir=/$PACKAGE_NAME/perl
+# default user, group
+defaultuser=nobody
+defaultgroup=nobody
+
AC_SUBST(configdir)
AC_SUBST(sampledatadir)
AC_SUBST(propertydir)
@@ -207,6 +211,9 @@ AC_SUBST(scripttemplatedir)
AC_SUBST(perldir)
AC_SUBST(infdir)
+AC_SUBST(defaultuser)
+AC_SUBST(defaultgroup)
+
# check for --with-instconfigdir
AC_MSG_CHECKING(for --with-instconfigdir)
AC_ARG_WITH(instconfigdir,
@@ -228,7 +235,6 @@ AC_SUBST(instconfigdir)
# cygnus, mingw, or the like and using cmd.exe as the shell
AM_CONDITIONAL([WINNT], false)
-shared_lib_suffix=.so
# Deal with platform dependent defines
# relative to sysconfdir
initdir=/rc.d
@@ -266,7 +272,6 @@ case $host in
AC_DEFINE([OS_hpux], [1], [OS HP-UX])
AC_DEFINE([_POSIX_C_SOURCE], [199506L], [POSIX revision])
AC_DEFINE([_HPUX_SOURCE], [1], [Source namespace])
- shared_lib_suffix=.sl
platform="hpux"
;;
sparc-sun-solaris*)
@@ -302,7 +307,6 @@ dnl Cstd and Crun are required to link any C++ related code
;;
esac
AC_SUBST(initdir)
-AC_SUBST(shared_lib_suffix)
AM_CONDITIONAL(HPUX,test "$platform" = "hpux")
AM_CONDITIONAL(SOLARIS,test "$platform" = "solaris")