summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRich Megginson <rmeggins@redhat.com>2008-07-15 15:50:56 +0000
committerRich Megginson <rmeggins@redhat.com>2008-07-15 15:50:56 +0000
commit0bcf4f075f6ac857d60464f4d259374a9929ab2b (patch)
treee2d03b42d41542ac4373123c355f104a28ff3cc5 /configure.ac
parent58bd25b8ce1ecd09d19aae31f6a989928d0413ed (diff)
downloadds-0bcf4f075f6ac857d60464f4d259374a9929ab2b.tar.gz
ds-0bcf4f075f6ac857d60464f4d259374a9929ab2b.tar.xz
ds-0bcf4f075f6ac857d60464f4d259374a9929ab2b.zip
Resolves: bug 447614
Bug Description: Lack of manpages Reviewed by: nhosoi (Thanks!) Branch: HEAD Fix Description: This adds man pages for the command line utilities. The configure.ac diffs were a little bit tricky - apparently, mandir is not set to a correct default value, so we have to make sure we set a reasonable default value it if the user has not set it (e.g. rpmbuild will override it with --mandir=something). Platforms tested: Fedora 8, Fedora 9 Flag Day: no Doc impact: no
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 8 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d37556c8..a6ca0192 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2,7 +2,7 @@
# Process this file with autoconf to produce a configure script.
AC_PREREQ(2.59)
# This version is the version returned by ns-slapd -v
-AC_INIT([dirsrv], [1.1.1], [http://bugzilla.redhat.com/])
+AC_INIT([dirsrv], [1.1.2], [http://bugzilla.redhat.com/])
# AC_CONFIG_HEADER must be called right after AC_INIT.
AC_CONFIG_HEADERS([config.h])
AM_INIT_AUTOMAKE([1.9 foreign subdir-objects])
@@ -214,6 +214,12 @@ else
perldir=/$PACKAGE_NAME/perl
fi
+# if mandir is the default value, override it
+# otherwise, the user must have set it - just use it
+if test X"$mandir" = X'${prefix}/man' ; then
+ mandir='$(datadir)/man'
+fi
+
# Shared paths for all layouts
# relative to sysconfdir
configdir=/$PACKAGE_NAME/config
@@ -234,6 +240,7 @@ AC_SUBST(scripttemplatedir)
AC_SUBST(perldir)
AC_SUBST(infdir)
AC_SUBST(mibdir)
+AC_SUBST(mandir)
AC_SUBST(defaultuser)
AC_SUBST(defaultgroup)