summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRich Megginson <rmeggins@redhat.com>2010-05-04 16:12:35 -0600
committerRich Megginson <rmeggins@redhat.com>2010-05-05 09:30:59 -0600
commitfe4d09a3f984fe821635a1147da12dc3510cd4d6 (patch)
treee75fa4410beec2fd5a6b6d6c4deeeb8a6fd3f210 /Makefile.am
parenta0b60b0b87c034f7f888b3ec0a86c4bca74f471d (diff)
downloadds-fe4d09a3f984fe821635a1147da12dc3510cd4d6.tar.gz
ds-fe4d09a3f984fe821635a1147da12dc3510cd4d6.tar.xz
ds-fe4d09a3f984fe821635a1147da12dc3510cd4d6.zip
Bug 586571 - DS Console shows escaped DNs
https://bugzilla.redhat.com/show_bug.cgi?id=586571 Resolves: bug 586571 Bug Description: DS Console shows escaped DNs Reviewed by: nkinder (Thanks!) Branch: HEAD Fix Description: In order for the console fixed to be used to manage the correct directory server, the directory server needs to be able to specify the ds console jar file version down to 3 digits, as opposed to the current two digits. To support this, instead of overriding PACKAGE_BASE_VERSION, a new configure macro is introduced - CONSOLE_VERSION. This value is set in VERSION.sh, so it can be easily updated, and it is used to set the value for BaseVersion in slapd.inf, which is what the admin server setup uses to set the ds console jar file version corresponding to the directory server. Platforms tested: RHEL5 x86_64, Fedora 12 Flag Day: no Doc impact: no
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 9d1bee6b..f013a100 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1332,6 +1332,7 @@ fixupcmd = sed \
-e 's,@PACKAGE_NAME\@,$(PACKAGE_NAME),g' \
-e 's,@PACKAGE_VERSION\@,$(PACKAGE_VERSION),g' \
-e 's,@PACKAGE_BASE_VERSION\@,$(PACKAGE_BASE_VERSION),g' \
+ -e 's,@CONSOLE_VERSION\@,$(CONSOLE_VERSION),g' \
-e 's,@BUILDNUM\@,$(BUILDNUM),g' \
-e 's,@NQBUILD_NUM\@,$(NQBUILDNUM),g' \
-e 's,@perlpath\@,$(perldir) $(libdir)/perl/arch $(libdir)/perl,g' \
@@ -1386,6 +1387,7 @@ fixupcmd = sed \
-e 's,@PACKAGE_NAME\@,$(PACKAGE_NAME),g' \
-e 's,@PACKAGE_VERSION\@,$(PACKAGE_VERSION),g' \
-e 's,@PACKAGE_BASE_VERSION\@,$(PACKAGE_BASE_VERSION),g' \
+ -e 's,@CONSOLE_VERSION\@,$(CONSOLE_VERSION),g' \
-e 's,@BUILDNUM\@,$(BUILDNUM),g' \
-e 's,@NQBUILD_NUM\@,$(NQBUILDNUM),g' \
-e 's,@perlpath\@,$(perldir),g' \