summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRich Megginson <rmeggins@redhat.com>2010-02-16 15:56:59 -0700
committerRich Megginson <rmeggins@redhat.com>2010-02-17 15:05:40 -0700
commitecf93e699b04d45fdfa07b12094adaab0233c47a (patch)
treec8725f13871e4d45cd97aec529417289234c8676 /Makefile.am
parent6adbad044ef95411882ec546281a0df6d0816673 (diff)
downloadds-ecf93e699b04d45fdfa07b12094adaab0233c47a.tar.gz
ds-ecf93e699b04d45fdfa07b12094adaab0233c47a.tar.xz
ds-ecf93e699b04d45fdfa07b12094adaab0233c47a.zip
change syntax plugins to register required matching rule plugins
https://bugzilla.redhat.com/show_bug.cgi?id=559315 Resolves: 559315 Description: Searching some attributes are now case sensitive when they were previously case-insensitive Reviewed by: nhosoi (Thanks!) - also added some suggested comments I added code to allow the syntax plugins to register corresponding matching rules. That is, the functions that the syntax plugins use for filter matching and key generation can also be used for matching rules with the new wrapper code. I added some convenience functions and structures in the syntax plugin code to make it easier to add matching rules in the future. I also added a new feature to the matching rule code - in the LDAP spec definition of matching rule, the syntax provided in the matching rule definition is the syntax for the _assertion value_ used with the matching rule, which is not necessarily the same as the syntax of the _attribute values_ to which the matching rule can be applied. For example, matching rules that apply to syntax DirectoryString can also be applied in some cases to PrintableString, CountryString, and IA5String. There are several other cases like this as well. I also introduced the concept of a compat syntax that can be used with a matching rule. The server will now check, when reading in the schema, if the syntax and matching rules for an attribute are consistent. Finally, for 05rfc4523.ldif, I changed the attributes to use octetStringMatch instead of one of the unimplemented certificate matching rules.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index d2c52ffd..1774ccdc 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1047,6 +1047,7 @@ libsyntax_plugin_la_SOURCES = ldap/servers/plugins/syntaxes/bin.c \
ldap/servers/plugins/syntaxes/phonetic.c \
ldap/servers/plugins/syntaxes/sicis.c \
ldap/servers/plugins/syntaxes/string.c \
+ ldap/servers/plugins/syntaxes/syntax_common.c \
ldap/servers/plugins/syntaxes/tel.c \
ldap/servers/plugins/syntaxes/telex.c \
ldap/servers/plugins/syntaxes/teletex.c \