summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRich Megginson <rmeggins@redhat.com>2009-08-11 14:37:44 -0600
committerRich Megginson <rmeggins@redhat.com>2009-08-11 15:17:44 -0600
commit886d9b9f4fd9bfd72c2c9728f13b8db1ff2793b7 (patch)
tree7afa75c8dd680409fe7049827cf0a4f2905036a5 /Makefile.am
parentabff3feacb218a7bb65a358dce2e9c90a2f185b1 (diff)
downloadds-886d9b9f4fd9bfd72c2c9728f13b8db1ff2793b7.tar.gz
ds-886d9b9f4fd9bfd72c2c9728f13b8db1ff2793b7.tar.xz
ds-886d9b9f4fd9bfd72c2c9728f13b8db1ff2793b7.zip
Change default branding to 389 - remove lite code
The vendor, brand, and capbrand are set in configure - we should use those everywhere rather than have to run some sort of script over the code to change vendor, brand, version, etc. I've added VENDOR, BRAND, CAPBRAND to the default defines passed to the compiler, and changed the code to use these defines. And instead of the unintuitively named PRODUCTTEXT macro, we should use the already defined PRODUCT_VERSION. This allowed me to get rid of some code. The version was from a generated file called dirver.h which we don't need anymore, and we don't need the perl script dirver.pl which generated it. The vendor string was coming from the dirlite header file. So I also used this as an excuse to get rid of all references to dirlite once and for all (yay!). For the places in plain text files which are not substituted, I just used the generic name Dirsrv or Directory Server instead of having an explicit brand and/or version in there. Reviewed by: nkinder (Thanks!)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 5 insertions, 9 deletions
diff --git a/Makefile.am b/Makefile.am
index f0123f08..c49162b7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -11,7 +11,7 @@ QUOTE := $(NULLSTRING)"# a double quote"
BUILDNUM := $(shell perl $(srcdir)/buildnum.pl)
NQBUILDNUM := $(subst \,,$(subst $(QUOTE),,$(BUILDNUM)))
DEBUG_DEFINES = @debug_defs@
-DS_DEFINES = -DBUILD_NUM=$(BUILDNUM)
+DS_DEFINES = -DBUILD_NUM=$(BUILDNUM) -DVENDOR="\"$(vendor)\"" -DBRAND="\"$(brand)\"" -DCAPBRAND="\"$(capbrand)\""
DS_INCLUDES = -I$(srcdir)/ldap/include -I$(srcdir)/ldap/servers/slapd -I$(srcdir)/include -I.
# these paths are dependent on the settings of prefix and exec_prefix which may be specified
# at make time. So we cannot use AC_DEFINE in the configure.ac because that would set the
@@ -63,9 +63,9 @@ LIBCRUN=@LIBCRUN@
#------------------------
# Generated Sources
#------------------------
-BUILT_SOURCES = dirver.h dberrstrs.h
+BUILT_SOURCES = dberrstrs.h
-CLEANFILES = dirver.h dberrstrs.h ns-slapd.properties \
+CLEANFILES = dberrstrs.h ns-slapd.properties \
ldap/admin/src/scripts/dscreate.map ldap/admin/src/scripts/remove-ds.pl \
ldap/admin/src/scripts/DSCreate.pm ldap/admin/src/scripts/DSMigration.pm \
ldap/admin/src/scripts/dsorgentries.map ldap/admin/src/scripts/migrate-ds.pl \
@@ -92,9 +92,6 @@ CLEANFILES = dirver.h dberrstrs.h ns-slapd.properties \
ldap/ldif/template-orgunit.ldif ldap/ldif/template-pampta.ldif ldap/ldif/template-sasl.ldif \
ldap/ldif/template-state.ldif ldap/ldif/template-suffix-db.ldif
-dirver.h: Makefile
- perl $(srcdir)/dirver.pl -v "$(VERSION)" -o dirver.h
-
dberrstrs.h: Makefile
perl $(srcdir)/ldap/servers/slapd/mkDBErrStrs.pl -i @db_incdir@ -o .
@@ -1117,7 +1114,6 @@ ns_slapd_SOURCES = ldap/servers/slapd/abandon.c \
ldap/servers/slapd/globals.c \
ldap/servers/slapd/house.c \
ldap/servers/slapd/init.c \
- ldap/servers/slapd/lite_entries.c \
ldap/servers/slapd/main.c \
ldap/servers/slapd/monitor.c \
ldap/servers/slapd/passwd_extop.c \
@@ -1169,9 +1165,9 @@ rsearch_bin_LDADD = $(NSPR_LINK) $(NSS_LINK) $(LDAPSDK_LINK) $(SASL_LINK) $(LIBS
# these are for the config files and scripts that we need to generate and replace
# the paths and other tokens with the real values set during configure/make
# note that we cannot just use AC_OUTPUT to do this for us, since it will do things like this:
-# LD_LIBRARY_PATH = ${prefix}/lib/fedora-ds
+# LD_LIBRARY_PATH = ${prefix}/lib/dirsrv
# i.e. it literally copies in '${prefix}' rather than expanding it out - we want this instead:
-# LD_LIBRARY_PATH = /usr/lib/fedora-ds
+# LD_LIBRARY_PATH = /usr/lib/dirsrv
if BUNDLE
# on the systems on which we bundle, perldap will be in libdir/perl, so we need to point
# the perlpath there - on other systems, perldap will be installed as a site module into