summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorNathan Kinder <nkinder@redhat.com>2007-06-08 23:19:20 +0000
committerNathan Kinder <nkinder@redhat.com>2007-06-08 23:19:20 +0000
commit85eefc580b0dc619292325319a7bb261dd698e15 (patch)
tree9cb86c2de3097d356db3b34d2b970c16971d3635 /Makefile.am
parentd9b8787008e72e696b2b92f20e18b4c3f5f0a38c (diff)
downloadds-85eefc580b0dc619292325319a7bb261dd698e15.tar.gz
ds-85eefc580b0dc619292325319a7bb261dd698e15.tar.xz
ds-85eefc580b0dc619292325319a7bb261dd698e15.zip
Resolves: 240583
Summary: Added SASL support to ldclt as well as some thread-safety fixes for ns-slapd when using SASL.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 8bebecd9..3f0baf49 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -867,7 +867,8 @@ ldap_agent_bin_LDADD = $(NETSNMP_LINK)
#------------------------
# ldclt
#------------------------
-ldclt_bin_SOURCES = ldap/servers/slapd/tools/ldclt/data.c \
+ldclt_bin_SOURCES = ldap/servers/slapd/tools/ldaptool-sasl.c \
+ ldap/servers/slapd/tools/ldclt/data.c \
ldap/servers/slapd/tools/ldclt/ldapfct.c \
ldap/servers/slapd/tools/ldclt/ldclt.c \
ldap/servers/slapd/tools/ldclt/ldcltU.c \
@@ -883,7 +884,7 @@ if SOLARIS
ldclt_bin_SOURCES += ldap/servers/slapd/tools/ldclt/opCheck.c
endif
-ldclt_bin_CPPFLAGS = $(AM_CPPFLAGS) @ldapsdk_inc@ @nss_inc@ @nspr_inc@
+ldclt_bin_CPPFLAGS = $(AM_CPPFLAGS) -I$(srcdir)/ldap/servers/slapd/tools @ldapsdk_inc@ @sasl_inc@ @nss_inc@ @nspr_inc@
ldclt_bin_LDADD = $(NSPR_LINK) $(NSS_LINK) $(LDAPSDK_LINK) $(SASL_LINK) $(LIBNSL) $(LIBSOCKET) $(LIBDL)
#------------------------