summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorNathan Kinder <nkinder@redhat.com>2009-09-22 08:39:12 -0700
committerNathan Kinder <nkinder@redhat.com>2009-09-22 08:39:12 -0700
commit58b0496f82c8fbf30ef9c36f4d7b6c24578522db (patch)
tree10d7cf501ffa21591f4dce037676ce235368b279 /Makefile.am
parentc11f1818c19233bdb6e54823b0c1352d4377fb75 (diff)
downloadds-58b0496f82c8fbf30ef9c36f4d7b6c24578522db.tar.gz
ds-58b0496f82c8fbf30ef9c36f4d7b6c24578522db.tar.xz
ds-58b0496f82c8fbf30ef9c36f4d7b6c24578522db.zip
Don't build policy module from Makefile.
This removes the Makefile rule that builds the SELinux policy module. The removed rule was only building and installing the module for the targeted policy. There are different base policies (targeted, strict, mls) on different systems, so it makes more sense to build the policy module from the spec file where we can define the available base policy types for the platform in question. We still need a "--with-selinux" option to enable the SELinux specific setup code as well as creating the policy .fc file with the proper paths that are defined at build time.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 3 insertions, 9 deletions
diff --git a/Makefile.am b/Makefile.am
index f7931206..b8724cad 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -63,7 +63,8 @@ LIBCRUN=@LIBCRUN@
#------------------------
# Generated Sources
#------------------------
-BUILT_SOURCES = dberrstrs.h
+BUILT_SOURCES = dberrstrs.h \
+ $(POLICY_FC)
CLEANFILES = dberrstrs.h ns-slapd.properties \
ldap/admin/src/scripts/template-dbverify ldap/admin/src/template-initconfig \
@@ -107,10 +108,6 @@ selinux-built:
selinux-built/dirsrv.fc: selinux-built
$(fixupcmd) selinux-built/dirsrv.fc.in > $@
-selinux-built/dirsrv.pp: selinux-built/dirsrv.fc
- cd selinux-built && $(MAKE)
-
-
#------------------------
# Install Paths
@@ -128,7 +125,6 @@ instconfigdir = @instconfigdir@
perldir = $(libdir)@perldir@
infdir = $(datadir)@infdir@
mibdir = $(datadir)@mibdir@
-policydir = $(datadir)/selinux/targeted
updatedir = $(datadir)@updatedir@
defaultuser=@defaultuser@
@@ -168,7 +164,7 @@ enable_presence = off
endif
if SELINUX
-POLICY_MODULE = selinux-built/dirsrv.pp
+POLICY_FC = selinux-built/dirsrv.fc
endif
serverplugin_LTLIBRARIES = libacl-plugin.la libattr-unique-plugin.la \
@@ -191,8 +187,6 @@ noinst_LIBRARIES = libavl.a libldaputil.a
#------------------------
# Installed Files
#------------------------
-policy_DATA = $(POLICY_MODULE)
-
config_DATA = $(srcdir)/lib/ldaputil/certmap.conf \
$(srcdir)/ldap/schema/slapd-collations.conf \
ldap/admin/src/template-initconfig \