summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorNathan Kinder <nkinder@redhat.com>2007-02-16 23:25:06 +0000
committerNathan Kinder <nkinder@redhat.com>2007-02-16 23:25:06 +0000
commit47d5f680b42c229bdeef0be7fe8a046a7443a41b (patch)
tree2846d72c95d91d27b432a1d124c6f05a86bf168e /Makefile.am
parent158fc7b78cd8e54be408a2ab9dd4542e6e703d0c (diff)
downloadds-47d5f680b42c229bdeef0be7fe8a046a7443a41b.tar.gz
ds-47d5f680b42c229bdeef0be7fe8a046a7443a41b.tar.xz
ds-47d5f680b42c229bdeef0be7fe8a046a7443a41b.zip
Resolves: 229095
Summary: Fixed build flags for compiling with pthread on HP-UX.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 3fcf60d4..a16198e9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -25,6 +25,10 @@ PATH_DEFINES = -DLOCALSTATEDIR="\"$(localstatedir)\"" -DSYSCONFDIR="\"$(sysconfd
AM_CPPFLAGS = $(DEBUG_DEFINES) $(DS_DEFINES) $(DS_INCLUDES) $(PATH_DEFINES)
PLUGIN_CPPFLAGS = $(AM_CPPFLAGS) @ldapsdk_inc@ @nss_inc@ @nspr_inc@
+# We need to make sure that libpthread is linked before libc on HP-UX.
+if HPUX
+AM_LDFLAGS = -lpthread
+endif
#------------------------
# Linker Flags