summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorNathan Kinder <nkinder@redhat.com>2009-10-26 15:18:09 -0700
committerNathan Kinder <nkinder@redhat.com>2009-10-26 15:18:09 -0700
commit333c980bf3d3729e21149bcd4deab38d4b4ca9aa (patch)
treecdd98e419d18ae9741dea8541f95075cd47674d1 /Makefile.am
parent41fa124aeec3b6bc86f28d69aeccb0e02f382aeb (diff)
downloadds-333c980bf3d3729e21149bcd4deab38d4b4ca9aa.tar.gz
ds-333c980bf3d3729e21149bcd4deab38d4b4ca9aa.tar.xz
ds-333c980bf3d3729e21149bcd4deab38d4b4ca9aa.zip
BZ 221905 - Add SMD5 password storage support.
This adds SMD5 password storage support to the existing password storage plug-in. Add upgrade LDIF has been added to ensure that this new functionality will be available to servers that are upgraded from previous versions.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index c34e6fe3..676b5cf4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -418,6 +418,7 @@ update_DATA = ldap/admin/src/scripts/exampleupdate.pl \
ldap/admin/src/scripts/50guidesyntaxplugin.ldif \
ldap/admin/src/scripts/50linkedattrsplugin.ldif \
ldap/admin/src/scripts/50usnplugin.ldif \
+ ldap/admin/src/scripts/50smd5pwdstorageplugin.ldif \
ldap/admin/src/scripts/60upgradeschemafiles.pl \
ldap/admin/src/scripts/dnaplugindepends.ldif
@@ -902,7 +903,9 @@ libpwdstorage_plugin_la_SOURCES = ldap/servers/plugins/pwdstorage/clear_pwd.c \
ldap/servers/plugins/pwdstorage/md5c.c \
ldap/servers/plugins/pwdstorage/ns-mta-md5_pwd.c \
ldap/servers/plugins/pwdstorage/pwd_init.c \
+ ldap/servers/plugins/pwdstorage/pwd_util.c \
ldap/servers/plugins/pwdstorage/sha_pwd.c \
+ ldap/servers/plugins/pwdstorage/smd5_pwd.c \
ldap/servers/plugins/pwdstorage/ssha_pwd.c
libpwdstorage_plugin_la_CPPFLAGS = $(PLUGIN_CPPFLAGS)