summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRich Megginson <rmeggins@redhat.com>2009-11-24 12:16:23 -0700
committerRich Megginson <rmeggins@redhat.com>2009-11-25 11:10:10 -0700
commit16e255be98bbb8b3bcfb080c632add7f048cfd44 (patch)
tree5c28a326b327c95ffb38ca2f9fcce19b5c684dea /Makefile.am
parentb2e2a3f5294707e1ccf2b25fd281ce3653dac819 (diff)
downloadds-16e255be98bbb8b3bcfb080c632add7f048cfd44.tar.gz
ds-16e255be98bbb8b3bcfb080c632add7f048cfd44.tar.xz
ds-16e255be98bbb8b3bcfb080c632add7f048cfd44.zip
Add Named Pipe Log Script, plugins, man page
The Named Pipe Log Script allows you to replace a log file with a named pipe attached to a script. The server can then send the log output to a script instead of to a log file. This allows you to do many different things such as: * log only certain events e.g. failed binds, connections from certain ip addresses, etc. * log only lines that match a certain pattern * log only the last N lines - useful for enabling full error log debug levels in production environments * send an email or other notification when a certain event is detected The script is written in python, and allows plugins. By default, the script will log the last N lines (default 1000). There are two plugins provided - one to log only failed bind attempts, and one that will log only lines that match given regular expressions. Reviewed by: nkinder (Thanks!) - found a bug in a comment Resolves: bug 486171 Bug Description: [RFE] Access log - Failed binds
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 95eec142..dbab95ed 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -199,7 +199,9 @@ config_DATA = $(srcdir)/lib/ldaputil/certmap.conf \
# with the default schema e.g. there is
# considerable overlap of 60changelog.ldif and 01common.ldif
# and 60inetmail.ldif and 50ns-mail.ldif among others
-sampledata_DATA = $(srcdir)/ldap/ldif/Ace.ldif \
+sampledata_DATA = ldap/admin/src/scripts/failedbinds.py \
+ ldap/admin/src/scripts/logregex.py \
+ $(srcdir)/ldap/ldif/Ace.ldif \
$(srcdir)/ldap/ldif/European.ldif \
$(srcdir)/ldap/ldif/Eurosuffix.ldif \
$(srcdir)/ldap/ldif/Example.ldif \
@@ -291,7 +293,8 @@ bin_SCRIPTS = ldap/servers/slapd/tools/rsearch/scripts/dbgen.pl \
wrappers/cl-dump \
ldap/admin/src/scripts/cl-dump.pl \
wrappers/repl-monitor \
- ldap/admin/src/scripts/repl-monitor.pl
+ ldap/admin/src/scripts/repl-monitor.pl \
+ ldap/admin/src/scripts/ds-logpipe.py
# SCRIPTS makes them executables - these are perl modules
# and should not be marked as executable - so use DATA
@@ -369,6 +372,7 @@ mib_DATA = ldap/servers/snmp/RFC-1215.txt \
dist_man_MANS = man/man1/dbscan.1 \
man/man1/cl-dump.1 \
man/man1/dbgen.pl.1 \
+ man/man1/ds-logpipe.py.1 \
man/man1/dsktune.1 \
man/man1/infadd.1 \
man/man1/ldap-agent.1 \