summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRichard W.M. Jones <rjones@redhat.com>2011-05-26 15:40:59 +0100
committerRichard W.M. Jones <rjones@redhat.com>2011-05-26 15:55:41 +0100
commit3ea952163f0c28cd88f8473bb015df892c4247bf (patch)
tree8363809b506ac8f2aa32983d9f7a1c0037cc462e /configure.ac
parent4fbbc8153ab74d5448bbb6d1113f1bc39f55402a (diff)
downloadvirt-what-3ea952163f0c28cd88f8473bb015df892c4247bf.tar.gz
virt-what-3ea952163f0c28cd88f8473bb015df892c4247bf.tar.xz
virt-what-3ea952163f0c28cd88f8473bb015df892c4247bf.zip
Add IA64-specific tests for virtualization (RHBZ#707508).
Xen IA64 HVM does not provide a simple way to detect the hypervisor. If we are lucky and PV-on-HVM drivers are installed and loaded, then there will be a /sys/bus/xen directory. Otherwise we add a timing attack to see if we can detect generic virtualization. Since this is a big hack, it is only enabled on IA64 and only used when all other methods of detection have failed. This commit also adds `uname -p` to all tests (enabling arch detection so we only run the above tests on IA64).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0aa7deb..8e75938 100644
--- a/configure.ac
+++ b/configure.ac
@@ -28,6 +28,10 @@ test "x$U" != "x" && AC_MSG_ERROR([Compiler not ANSI compliant])
AM_PROG_CC_C_O
+dnl Architecture we are compiling for.
+AC_CANONICAL_HOST
+AM_CONDITIONAL([HOST_CPU_IA64], [ test "x$host_cpu" = "xia64" ])
+
dnl Produce output files.
AC_CONFIG_HEADERS([config.h])
AC_CONFIG_FILES([virt-what],[chmod +x virt-what])