summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRichard Jones <rjones@trick.home.annexia.org>2009-07-23 09:18:57 +0100
committerRichard Jones <rjones@trick.home.annexia.org>2009-07-23 09:59:36 +0100
commitb8957a6bd16be4c6c2c2893d621ed84bf21d0f72 (patch)
tree8b5791bac62a62cbb03db9b31260a5dee4625e03 /Makefile.am
parent7880dab8d6e6d85cb086960750916b7f578e537f (diff)
downloadvirt-what-b8957a6bd16be4c6c2c2893d621ed84bf21d0f72.tar.gz
virt-what-b8957a6bd16be4c6c2c2893d621ed84bf21d0f72.tar.xz
virt-what-b8957a6bd16be4c6c2c2893d621ed84bf21d0f72.zip
Autoconfify, add CPUID helper program to detect HVM domains (Paolo Bonzini).1.1
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am32
1 files changed, 32 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..1c9777f
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,32 @@
+# Makefile for virt-what
+# Copyright (C) 2008-2009 Red Hat Inc.
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+
+EXTRA_DIST = virt-what.in virt-what.pod
+
+AM_CPPFLAGS = -Wall
+
+bin_SCRIPTS = virt-what
+bin_PROGRAMS = virt-what-cpuid-helper
+
+man_MANS = virt-what.1
+
+virt-what.1: virt-what.pod
+ pod2man -c "Virtualization Support" --release "$(PACKAGE)-$(VERSION)" \
+ $< > $@
+
+virt-what.txt: virt-what.pod
+ pod2text $< > $@