summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRichard W.M. Jones <rjones@redhat.com>2011-01-26 23:39:40 +0000
committerRichard W.M. Jones <rjones@redhat.com>2011-01-26 23:43:00 +0000
commit0e90af4014da8065a4062319921288baf972c6fb (patch)
tree2802993265c308f0d6eb3cd9aa7d968c46f1ada8 /Makefile.am
parent80499c7119791248ff9ffc20f575be13fbc83534 (diff)
downloadvirt-what-0e90af4014da8065a4062319921288baf972c6fb.tar.gz
virt-what-0e90af4014da8065a4062319921288baf972c6fb.tar.xz
virt-what-0e90af4014da8065a4062319921288baf972c6fb.zip
Confirm Microsoft Hyper-V, and add a regression test.
Data collected from a RHEL 5.6 guest running on Hyper-V. Also this modifies the VirtualPC test slightly to distinguish it from Hyper-V. We require more data from a real VirtualPC guest to properly refine this test.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 42ec069..869f692 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -28,6 +28,11 @@ EXTRA_DIST = \
tests/esx4.1/sbin/dmidecode \
tests/esx4.1/sbin/id \
tests/esx4.1/sbin/virt-what-cpuid-helper \
+ tests/hyperv/proc/cpuinfo \
+ tests/hyperv/proc/self/status \
+ tests/hyperv/sbin/dmidecode \
+ tests/hyperv/sbin/id \
+ tests/hyperv/sbin/virt-what-cpuid-helper \
tests/kvm/proc/cpuinfo \
tests/kvm/proc/self/status \
tests/kvm/sbin/dmidecode \
@@ -109,6 +114,7 @@ EXTRA_DIST = \
tests/zvm/sbin/virt-what-cpuid-helper \
tests/test-baremetal.sh \
tests/test-esx4.1.sh \
+ tests/test-hyperv.sh \
tests/test-kvm.sh \
tests/test-linux-vserver.sh \
tests/test-parallels-desktop.sh \
@@ -137,6 +143,7 @@ virt-what.txt: virt-what.pod
TESTS = \
tests/test-baremetal.sh \
tests/test-esx4.1.sh \
+ tests/test-hyperv.sh \
tests/test-kvm.sh \
tests/test-linux-vserver.sh \
tests/test-parallels-desktop.sh \