summaryrefslogtreecommitdiffstats
path: root/perl/examples/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'perl/examples/Makefile.am')
-rw-r--r--perl/examples/Makefile.am39
1 files changed, 39 insertions, 0 deletions
diff --git a/perl/examples/Makefile.am b/perl/examples/Makefile.am
new file mode 100644
index 00000000..354531ac
--- /dev/null
+++ b/perl/examples/Makefile.am
@@ -0,0 +1,39 @@
+# libguestfs Perl examples
+# Copyright (C) 2011 Red Hat Inc.
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+
+EXTRA_DIST = \
+ LICENSE \
+ create_disk.pl \
+ inspect_vm.pl \
+ guestfs-perl.pod
+
+CLEANFILES = stamp-guestfs-perl.pod
+
+man_MANS = guestfs-perl.3
+noinst_DATA = $(top_builddir)/html/guestfs-perl.3.html
+
+guestfs-perl.3 $(top_builddir)/html/guestfs-perl.3.html: stamp-guestfs-perl.pod
+
+stamp-guestfs-perl.pod: guestfs-perl.pod create_disk.pl inspect_vm.pl
+ $(top_srcdir)/podwrapper.sh \
+ --section 3 \
+ --man guestfs-perl.3 \
+ --html $(top_builddir)/html/guestfs-perl.3.html \
+ --verbatim create_disk.pl:@EXAMPLE1@ \
+ --verbatim inspect_vm.pl:@EXAMPLE2@ \
+ $<
+ touch $@