summaryrefslogtreecommitdiffstats
path: root/perl/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'perl/Makefile.am')
-rw-r--r--perl/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/perl/Makefile.am b/perl/Makefile.am
index 52a6a094..5d661ced 100644
--- a/perl/Makefile.am
+++ b/perl/Makefile.am
@@ -22,6 +22,7 @@ EXTRA_DIST = \
examples/LICENSE \
examples/*.pl \
lib/Sys/Guestfs.pm \
+ run-bindtests \
run-perl-tests \
t/*.t \
typemap
@@ -31,7 +32,11 @@ if HAVE_PERL
# Interfacing automake and ExtUtils::MakeMaker known to be
# a nightmare, news at 11.
-TESTS = run-perl-tests
+TESTS = run-bindtests run-perl-tests
+
+TESTS_ENVIRONMENT = \
+ LD_LIBRARY_PATH=../src/.libs \
+ LIBGUESTFS_PATH=../appliance
INSTALLDIRS = site