summaryrefslogtreecommitdiffstats
path: root/ocaml/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ocaml/Makefile.am')
-rw-r--r--ocaml/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/ocaml/Makefile.am b/ocaml/Makefile.am
index e80d44a3..77c5be96 100644
--- a/ocaml/Makefile.am
+++ b/ocaml/Makefile.am
@@ -65,10 +65,12 @@ TESTS_ENVIRONMENT = \
TESTS = run-bindtests \
t/guestfs_005_load t/guestfs_010_launch t/guestfs_050_lvcreate \
t/guestfs_060_readdir t/guestfs_070_threads \
+ t/guestfs_080_optargs \
t/guestfs_400_progress
noinst_DATA += bindtests \
t/guestfs_005_load t/guestfs_010_launch t/guestfs_050_lvcreate \
t/guestfs_060_readdir t/guestfs_070_threads \
+ t/guestfs_080_optargs \
t/guestfs_400_progress
bindtests: bindtests.cmx mlguestfs.cmxa
@@ -95,6 +97,10 @@ t/guestfs_070_threads: t/guestfs_070_threads.cmx mlguestfs.cmxa
mkdir -p t
$(OCAMLFIND) ocamlopt -cclib -L$(top_builddir)/src/.libs -I . -package unix,threads -thread -linkpkg mlguestfs.cmxa $< -o $@
+t/guestfs_080_optargs: t/guestfs_080_optargs.cmx mlguestfs.cmxa
+ mkdir -p t
+ $(OCAMLFIND) ocamlopt -cclib -L$(top_builddir)/src/.libs -I . -package xml-light,unix -linkpkg mlguestfs.cmxa $< -o $@
+
t/guestfs_400_progress: t/guestfs_400_progress.cmx mlguestfs.cmxa
mkdir -p t
$(OCAMLFIND) ocamlopt -cclib -L$(top_builddir)/src/.libs -I . -package xml-light,unix -linkpkg mlguestfs.cmxa $< -o $@