summaryrefslogtreecommitdiffstats
path: root/tools/Makefile.am
diff options
context:
space:
mode:
authorRichard Jones <rjones@redhat.com>2010-05-12 14:24:23 +0100
committerRichard Jones <rjones@redhat.com>2010-05-12 18:13:01 +0100
commitfeb0cd04822231f056c3086f322afbefc2e2467c (patch)
tree0566c4adba327da4886f8bb8b1807634e418afd4 /tools/Makefile.am
parent48133118071a26950840fe33326c09130955c35e (diff)
downloadlibguestfs-feb0cd04822231f056c3086f322afbefc2e2467c.tar.gz
libguestfs-feb0cd04822231f056c3086f322afbefc2e2467c.tar.xz
libguestfs-feb0cd04822231f056c3086f322afbefc2e2467c.zip
po: Include strings from Perl programs in the PO files (RHBZ#559963).
xgettext will only recognize '*.pl' as being a Perl file (otherwise it treats it as a C file and does not correctly find any strings in it). This commit also fixes two actual bugs that xgettext found in the strings in our Perl programs.
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
index 9cc61399..ab14fe0f 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -1,5 +1,5 @@
# libguestfs virt-* tools
-# Copyright (C) 2009 Red Hat Inc.
+# Copyright (C) 2009-2010 Red Hat Inc.
#
# This program is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -89,3 +89,12 @@ TESTS = test-virt-cat.sh \
test-virt-tar.sh
endif
+
+# Make symlinks from virt-foo.pl to virt-foo. This is just to keep
+# xgettext happy since it uses the file extension to determine the
+# implementation language of a file.
+
+all-local: $(tools:%=virt-%.pl)
+
+virt-%.pl: virt-%
+ ln -sf $< $@