summaryrefslogtreecommitdiffstats
path: root/tools/Makefile.am
diff options
context:
space:
mode:
authorRichard W.M. Jones <rjones@redhat.com>2010-11-11 16:20:25 +0000
committerRichard W.M. Jones <rjones@redhat.com>2010-11-11 16:56:11 +0000
commit4d900cdac8258daa2e99c6ceb2a4985154e94150 (patch)
tree3405a12423aaadc9f31fbd0d467ebf0ba92d32ca /tools/Makefile.am
parent4d59e271046f2b5f0d9b1730cd23425fd631c76c (diff)
downloadlibguestfs-4d900cdac8258daa2e99c6ceb2a4985154e94150.tar.gz
libguestfs-4d900cdac8258daa2e99c6ceb2a4985154e94150.tar.xz
libguestfs-4d900cdac8258daa2e99c6ceb2a4985154e94150.zip
Generate a dummy 'Fedora' fedora.img in images directory for use by tests.
We were generating this dummy 'Fedora' image already in the tools directory. It contains just enough Fedora-like files to fool our inspection code and thus to test the tools. This is general enough that we can use it everywhere.
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am6
1 files changed, 0 insertions, 6 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
index b92243c0..5b415c0e 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -33,7 +33,6 @@ tools = \
EXTRA_DIST = \
run-locally \
$(tools:%=virt-%) \
- make-test-img.sh \
test-virt-*.sh
CLEANFILES = test.img
@@ -76,11 +75,6 @@ TESTS_ENVIRONMENT = \
LIBGUESTFS_PATH=$(top_builddir)/appliance \
PERL5LIB=$(top_builddir)/perl/blib/lib:$(top_builddir)/perl/blib/arch
-# Build a standard test image to be used by all these tests.
-check_DATA = test.img
-test.img: make-test-img.sh
- $(TESTS_ENVIRONMENT) $(srcdir)/make-test-img.sh
-
TESTS = test-virt-cat.sh \
test-virt-df.sh \
test-virt-list-filesystems.sh \