summaryrefslogtreecommitdiffstats
path: root/tools/Makefile.am
diff options
context:
space:
mode:
authorRichard W.M. Jones <rjones@redhat.com>2012-08-21 20:11:52 +0100
committerRichard W.M. Jones <rjones@redhat.com>2012-08-21 20:33:21 +0100
commit2f97bf873b64384835f257f8916bf1ebb2af62b4 (patch)
treead9bce03b85f906e6a0bf875c3898e58fd148218 /tools/Makefile.am
parentf1d98bbc79496947210ee0305f80440ed8557ec1 (diff)
downloadlibguestfs-2f97bf873b64384835f257f8916bf1ebb2af62b4.tar.gz
libguestfs-2f97bf873b64384835f257f8916bf1ebb2af62b4.tar.xz
libguestfs-2f97bf873b64384835f257f8916bf1ebb2af62b4.zip
podwrapper: Add --license parameter, which is required.
This adds standard LICENSE and BUGS sections to all of the man pages that are processed by podwrapper. Modify all the calls to $(PODWRAPPER) to add the right --license parameter according to the content. Note that this relaxes the license on some code example pages, making them effectively BSD-style licensed.
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
index 32a92e26..0ae92c56 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -46,11 +46,13 @@ noinst_DATA = $(tools:%=$(top_builddir)/html/virt-%.1.html)
virt-%.1: virt-%
$(PODWRAPPER) \
--man $@ \
+ --license GPLv2+ \
$<
$(top_builddir)/html/virt-%.1.html: virt-%
$(PODWRAPPER) \
--html $@ \
+ --license GPLv2+ \
$<
# Tests.