summaryrefslogtreecommitdiffstats
path: root/tools/Makefile.am
diff options
context:
space:
mode:
authorRichard Jones <rjones@redhat.com>2009-11-24 15:19:08 +0000
committerRichard Jones <rjones@redhat.com>2009-11-24 16:01:11 +0000
commit299d5b9dd260d47ac5121126ecd0e3f7bc4830b5 (patch)
tree934509c2fdefa3fde1676352a752af53e27ef7b1 /tools/Makefile.am
parent9b6185b9bf8147e20563608b23eaafce9c5edc2f (diff)
downloadlibguestfs-299d5b9dd260d47ac5121126ecd0e3f7bc4830b5.tar.gz
libguestfs-299d5b9dd260d47ac5121126ecd0e3f7bc4830b5.tar.xz
libguestfs-299d5b9dd260d47ac5121126ecd0e3f7bc4830b5.zip
New tool: virt-list-filesystems
Use this program as a convenient way to list the filesystems available in a disk image or libvirt guest. Example: $ virt-list-filesystems /dev/vg_trick/Debian5x64 /dev/debian5x64/home /dev/debian5x64/root /dev/debian5x64/tmp /dev/debian5x64/usr /dev/debian5x64/var /dev/sda1 This is designed to make it easier for novices to use guestfish and guestmount. In particular with guestmount this acts as a way to get a list of filesystems to use with the '-m' option. ie: $ virt-list-filesystems unknowndisk.img /dev/sda1 /dev/sda2 $ guestmount -a unknowndisk.img -m /dev/sda1 /mnt
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
index 3055ab74..6e6872c8 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -17,7 +17,7 @@
include $(top_srcdir)/subdir-rules.mk
-tools = cat df edit ls rescue tar win-reg
+tools = cat df edit list-filesystems ls rescue tar win-reg
EXTRA_DIST = \
run-locally \