summaryrefslogtreecommitdiffstats
path: root/test-tool/Makefile.am
diff options
context:
space:
mode:
authorRichard Jones <rjones@redhat.com>2010-01-29 14:56:13 +0000
committerRichard Jones <rjones@redhat.com>2010-01-29 15:11:59 +0000
commita6025c11d97ed5802b3729a93d224d2baa20ff12 (patch)
tree6dd670b706070e29496a62052447b22086434c0b /test-tool/Makefile.am
parent088d0c53cfe0dcb20b87707a9055175b2fd6b72f (diff)
downloadlibguestfs-a6025c11d97ed5802b3729a93d224d2baa20ff12.tar.gz
libguestfs-a6025c11d97ed5802b3729a93d224d2baa20ff12.tar.xz
libguestfs-a6025c11d97ed5802b3729a93d224d2baa20ff12.zip
Set locale in C programs so l10n works (RHBZ#559962).
This commit adds the calls to setlocale &c to all of the current C programs. It also adds l10n support to hivexget and hivexml which lacked them previously. To test this, try: LANG=pa_IN.UTF-8 guestfish --cmd-help (You can only do this test after installing the package, or at least the 'pa.mo' mo-file in the correct place).
Diffstat (limited to 'test-tool/Makefile.am')
-rw-r--r--test-tool/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/test-tool/Makefile.am b/test-tool/Makefile.am
index d58f1377..66d06e09 100644
--- a/test-tool/Makefile.am
+++ b/test-tool/Makefile.am
@@ -30,6 +30,7 @@ AM_CPPFLAGS = \
libguestfs_test_tool_SOURCES = test-tool.c
libguestfs_test_tool_CFLAGS = \
+ -DLOCALEBASEDIR=\""$(datadir)/locale"\" \
-I$(top_srcdir)/src -I$(top_builddir)/src \
-Wall
libguestfs_test_tool_LDADD = \