summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMasami HIRATA <msmhrt@gmail.com>2012-07-24 23:10:49 +0900
committerRichard W.M. Jones <rjones@redhat.com>2012-07-24 19:40:40 +0100
commitd74e7fad28ae7a2f894a12d30807f4b36078bf13 (patch)
tree0452581e4d073e1d99b3996759c98671de59bbc9 /src/Makefile.am
parent61c9ea496e0579bb7d1bcf496595d66c3f08cfec (diff)
downloadlibguestfs-d74e7fad28ae7a2f894a12d30807f4b36078bf13.tar.gz
libguestfs-d74e7fad28ae7a2f894a12d30807f4b36078bf13.tar.xz
libguestfs-d74e7fad28ae7a2f894a12d30807f4b36078bf13.zip
Mac OS X: Use u_int64_t/uint64_t instead of unsigned hyper in .x file
Signed-off-by: Masami HIRATA <msmhrt@gmail.com> RWMJ: Fixed whitespace in generator_xdr.ml
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am13
1 files changed, 11 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 95042f80..750c07be 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -180,16 +180,25 @@ libguestfs_la_LIBADD += $(FUSE_LIBS) -lulockmgr
endif
if HAVE_RPCGEN
+RPCGEN_DEFS =
+if HAVE_XDR_U_INT64_T
+RPCGEN_DEFS += -DHAVE_XDR_U_INT64_T=1
+else
+if HAVE_XDR_UINT64_T
+RPCGEN_DEFS += -DHAVE_XDR_UINT64_T=1
+endif
+endif
+
guestfs_protocol.c: guestfs_protocol.x
rm -f $@-t $@-t2
- $(RPCGEN) -c -o $@-t $(srcdir)/$<
+ $(RPCGEN) $(RPCGEN_DEFS) -c -o $@-t $(srcdir)/$<
sed 's,\.\./\(\.\./\)*src,.,' < $@-t > $@-t2
rm $@-t
mv $@-t2 $@
guestfs_protocol.h: guestfs_protocol.x
rm -f $@-t
- $(RPCGEN) -h -o $@-t $(srcdir)/$<
+ $(RPCGEN) $(RPCGEN_DEFS) -h -o $@-t $(srcdir)/$<
mv $@-t $@
endif