summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorRichard W.M. Jones <rjones@redhat.com>2011-12-14 08:44:41 +0000
committerRichard W.M. Jones <rjones@redhat.com>2012-03-29 16:45:01 +0100
commitc6f09fac0666260587f95bdfee3c20c9166dae94 (patch)
tree25b1b6493697034120508518dcfcbc6d34417156 /src/Makefile.am
parent49fdba0ae98b5b6995ccaf0f0ba4f542bfff7ce3 (diff)
downloadlibguestfs-c6f09fac0666260587f95bdfee3c20c9166dae94.tar.gz
libguestfs-c6f09fac0666260587f95bdfee3c20c9166dae94.tar.xz
libguestfs-c6f09fac0666260587f95bdfee3c20c9166dae94.zip
New APIs: mount-local, mount-local-run, umount-local (FUSE support in the API).
Add FUSE support directly to the API. Instead of needing to use the external 'guestmount' command, you can mount the libguestfs filesystem space on a local mountpoint using an API call from any language. Note that although mount-local-run is marked as Cancellable, the current implementation does not support it, but it would be relatively simple to add it.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index b91ffc1c..a7fcbac6 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,5 +1,5 @@
# libguestfs
-# Copyright (C) 2010 Red Hat Inc.
+# Copyright (C) 2010-2012 Red Hat Inc.
#
# This program is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -139,6 +139,7 @@ libguestfs_la_SOURCES = \
listfs.c \
match.c \
proto.c \
+ fuse.c \
virt.c \
libguestfs.syms
@@ -169,6 +170,12 @@ libguestfs_la_CFLAGS = \
libguestfs_la_CPPFLAGS = -I$(top_srcdir)/gnulib/lib -I$(top_builddir)/gnulib/lib
+if HAVE_FUSE
+# XXX Unfortunately FUSE_CFLAGS defines _FILE_OFFSET_BITS=64.
+libguestfs_la_CFLAGS += $(FUSE_CFLAGS)
+libguestfs_la_LIBADD += $(FUSE_LIBS) -lulockmgr
+endif
+
if HAVE_RPCGEN
guestfs_protocol.c: guestfs_protocol.x
rm -f $@-t $@-t2