summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorRichard W.M. Jones <rjones@redhat.com>2010-11-11 11:51:02 +0000
committerRichard W.M. Jones <rjones@redhat.com>2010-11-11 11:51:02 +0000
commit6263da7474c6e7818b025979712c9c5d7108640d (patch)
treec7cb9b69c0bbd1685d9ccd0914326092fc3d7549 /src/Makefile.am
parent4a3726d5ed0dd3174b46ec574eaf4f4140cb193b (diff)
downloadlibguestfs-6263da7474c6e7818b025979712c9c5d7108640d.tar.gz
libguestfs-6263da7474c6e7818b025979712c9c5d7108640d.tar.xz
libguestfs-6263da7474c6e7818b025979712c9c5d7108640d.zip
lib: Make <guestfs.h> be completely generated.
This removes the 'not-quite-separate' guestfs-actions.h and guestfs-structs.h files.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am7
1 files changed, 2 insertions, 5 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 5f796a03..87812741 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -19,8 +19,7 @@ include $(top_srcdir)/subdir-rules.mk
generator_built = \
guestfs_protocol.x \
- guestfs-structs.h \
- guestfs-actions.h \
+ guestfs.h
guestfs-internal-actions.h \
actions.c \
bindtests.c \
@@ -47,7 +46,7 @@ EXTRA_DIST = \
api-support/README \
api-support/update-from-tarballs.sh
-include_HEADERS = guestfs.h guestfs-actions.h guestfs-structs.h
+include_HEADERS = guestfs.h
lib_LTLIBRARIES = libguestfs.la
@@ -120,9 +119,7 @@ libguestfs_la_LDFLAGS += $(VERSION_SCRIPT_FLAGS)libguestfs.syms
libguestfs_la_SOURCES = \
guestfs.c \
guestfs.h \
- guestfs-actions.h \
guestfs-internal.h \
- guestfs-structs.h \
guestfs_protocol.h \
gettext.h \
actions.c \