summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorHilko Bengen <bengen@hilluzination.de>2011-12-05 18:35:57 +0100
committerRichard W.M. Jones <rjones@redhat.com>2011-12-06 08:10:00 +0000
commit43942b08cfbcf91bef29ec532f3d097a8519c982 (patch)
tree42cbbac71d701da18da7b691430ba9a5dba346ed /src/Makefile.am
parent2972987d0257d9c3d26b53f961e802d121b436cd (diff)
downloadlibguestfs-43942b08cfbcf91bef29ec532f3d097a8519c982.tar.gz
libguestfs-43942b08cfbcf91bef29ec532f3d097a8519c982.tar.xz
libguestfs-43942b08cfbcf91bef29ec532f3d097a8519c982.zip
Fix rpcgen post-processing for out-of-tree builds
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 82a40045..28a1b920 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -171,7 +171,7 @@ if HAVE_RPCGEN
guestfs_protocol.c: guestfs_protocol.x
rm -f $@-t $@-t2
$(RPCGEN) -c -o $@-t $(srcdir)/$<
- sed 's,\.\./\.\./src/,,' < $@-t > $@-t2
+ sed 's,\.\./\(\.\./\)*src,.,' < $@-t > $@-t2
rm $@-t
mv $@-t2 $@