summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorRichard W.M. Jones <rjones@redhat.com>2012-10-17 14:31:33 +0100
committerRichard W.M. Jones <rjones@redhat.com>2012-10-18 21:52:08 +0100
commit2e90f4312928f332f8997b52be3fe54f20920242 (patch)
treefc5365fbcd79d5ba261bb7c72b251f5531fb75ce /src/Makefile.am
parent2dab72794eef55f941cc61f1f34baa9fc7988298 (diff)
downloadlibguestfs-2e90f4312928f332f8997b52be3fe54f20920242.tar.gz
libguestfs-2e90f4312928f332f8997b52be3fe54f20920242.tar.xz
libguestfs-2e90f4312928f332f8997b52be3fe54f20920242.zip
lib: Add a new 'command' mini-library for running external commands.
This is a wrapper or mini-library for running external command, loosely based on libvirt's virCommand interface. Amongst the advantages are: - Can redirect errors into the error log (RHBZ#713678). - Can redirect output into a callback function. - Handles shell quoting properly. - Safely resets signal handlers, closes file descriptors, etc. - Single place where we can implement other improvements in future.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index b189c4a0..5f80bc1b 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -125,6 +125,7 @@ libguestfs_la_SOURCES = \
actions.c \
appliance.c \
bindtests.c \
+ command.c \
dbdump.c \
events.c \
file.c \