summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorRichard W.M. Jones <rjones@redhat.com>2012-07-19 15:45:27 +0100
committerRichard W.M. Jones <rjones@redhat.com>2012-07-19 16:11:47 +0100
commit2e4089f30007e79bc157c775cfd3b326d22f2992 (patch)
tree18fe8842961b4e22a0e857748d6d40476909fd17 /src/Makefile.am
parent6054051a9d8a5eee4141ca4b12aa5b7d1f36f56d (diff)
downloadlibguestfs-2e4089f30007e79bc157c775cfd3b326d22f2992.tar.gz
libguestfs-2e4089f30007e79bc157c775cfd3b326d22f2992.tar.xz
libguestfs-2e4089f30007e79bc157c775cfd3b326d22f2992.zip
build: Rename most C files that contain underscore with dash.
This is just code motion. Some files cannot be renamed. Notably rpcgen input and output files must not contain dash characters, else rpcgen breaks.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am20
1 files changed, 10 insertions, 10 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index ad641873..d956fdb3 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -25,7 +25,7 @@ generator_built = \
guestfs-internal-actions.h \
actions.c \
bindtests.c \
- errnostring_gperf.gperf \
+ errnostring-gperf.gperf \
errnostring.c \
errnostring.h \
guestfs-actions.pod \
@@ -37,7 +37,7 @@ BUILT_SOURCES = \
$(generator_built) \
guestfs_protocol.c \
guestfs_protocol.h \
- errnostring_gperf.c
+ errnostring-gperf.c
EXTRA_DIST = \
$(BUILT_SOURCES) \
@@ -62,12 +62,12 @@ libprotocol_la_CFLAGS = \
# Build the errnostring perfect hash code. The generated code has lots
# of warnings so we must compile it in a separate mini-library.
liberrnostring_la_SOURCES = \
- errnostring_gperf.c \
+ errnostring-gperf.c \
errnostring.h \
errnostring.c
liberrnostring_la_CFLAGS = $(GCC_VISIBILITY_HIDDEN)
-errnostring_gperf.c: errnostring_gperf.gperf
+errnostring-gperf.c: errnostring-gperf.gperf
rm -f $@
$(GPERF) -t $< > $@-t
mv $@-t $@
@@ -130,12 +130,12 @@ libguestfs_la_SOURCES = \
filearch.c \
fuse.c \
inspect.c \
- inspect_apps.c \
- inspect_fs.c \
- inspect_fs_cd.c \
- inspect_fs_unix.c \
- inspect_fs_windows.c \
- inspect_icon.c \
+ inspect-apps.c \
+ inspect-fs.c \
+ inspect-fs-cd.c \
+ inspect-fs-unix.c \
+ inspect-fs-windows.c \
+ inspect-icon.c \
launch.c \
libvirtdomain.c \
listfs.c \