summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorHilko Bengen <bengen@hilluzination.de>2011-12-01 22:06:30 +0100
committerRichard W.M. Jones <rjones@redhat.com>2011-12-01 23:40:58 +0000
commit1a35ca59088e572c11633e85524bb282cb436186 (patch)
treedb36e1cd978c328ebf21e71fdd543f37b5d19fe9 /src/Makefile.am
parentf23352aefd96dc873111e5e5d55ea22b30c3e0ad (diff)
downloadlibguestfs-1a35ca59088e572c11633e85524bb282cb436186.tar.gz
libguestfs-1a35ca59088e572c11633e85524bb282cb436186.tar.xz
libguestfs-1a35ca59088e572c11633e85524bb282cb436186.zip
libguestfs: Added gnulib includes from builddir, as suggested by the Gnulib documentation
Since some modules (`getopt', for example) may copy files into the build directory, `top_builddir/lib' is needed as well as `top_srcdir/lib'. -- GNU Gnulib manual, section 2.2 Initial import
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 761fcb6e..82a40045 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -165,7 +165,7 @@ libguestfs_la_CFLAGS = \
$(LIBVIRT_CFLAGS) $(LIBXML2_CFLAGS) \
$(WARN_CFLAGS) $(WERROR_CFLAGS)
-libguestfs_la_CPPFLAGS = -I$(top_srcdir)/gnulib/lib
+libguestfs_la_CPPFLAGS = -I$(top_srcdir)/gnulib/lib -I$(top_builddir)/gnulib/lib
if HAVE_RPCGEN
guestfs_protocol.c: guestfs_protocol.x