summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorOlaf Hering <olaf@aepfle.de>2012-08-29 15:15:12 +0200
committerRichard W.M. Jones <rjones@redhat.com>2012-08-29 16:42:51 +0100
commit044c5b26d7ed1bde70cbeacb0ffa3f8bcb932092 (patch)
treef779afef59191227a9ddbbe2c6c39832d4ce1c80 /src/Makefile.am
parent684efb3706795bdd8cb0d4c026067fb4d70e23d1 (diff)
downloadlibguestfs-044c5b26d7ed1bde70cbeacb0ffa3f8bcb932092.tar.gz
libguestfs-044c5b26d7ed1bde70cbeacb0ffa3f8bcb932092.tar.xz
libguestfs-044c5b26d7ed1bde70cbeacb0ffa3f8bcb932092.zip
remove ulockmgr from fuse LDFLAGS
libguestfs fails to build with --enable-fuse on openSuSE 11.4 and earlier because the included fuse version does not include libulockmgr.so. configure already used pkgconfig to retrieve the correct CFLAGS, so there is no need to hardcode -lulockmgr. With this change the build succeeds again. Signed-off-by: Olaf Hering <olaf@aepfle.de>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 4d857475..97905bf9 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -177,7 +177,7 @@ libguestfs_la_CPPFLAGS = -I$(top_srcdir)/gnulib/lib -I$(top_builddir)/gnulib/lib
if HAVE_FUSE
# XXX Unfortunately FUSE_CFLAGS defines _FILE_OFFSET_BITS=64.
libguestfs_la_CFLAGS += $(FUSE_CFLAGS)
-libguestfs_la_LIBADD += $(FUSE_LIBS) -lulockmgr
+libguestfs_la_LIBADD += $(FUSE_LIBS)
endif
if HAVE_RPCGEN