summaryrefslogtreecommitdiffstats
path: root/ruby/Makefile.am
diff options
context:
space:
mode:
authorRichard W.M. Jones <rjones@redhat.com>2011-08-08 12:41:54 +0100
committerRichard W.M. Jones <rjones@redhat.com>2011-08-08 12:41:54 +0100
commitf7d18c84dde596699ffc5100fec2cf7b0d582450 (patch)
tree0f1a43165ed98b3d53dc8081bd6a9d456ab2d539 /ruby/Makefile.am
parent54ea124b160eda705c96dfc664b4056848887856 (diff)
downloadlibguestfs-f7d18c84dde596699ffc5100fec2cf7b0d582450.tar.gz
libguestfs-f7d18c84dde596699ffc5100fec2cf7b0d582450.tar.xz
libguestfs-f7d18c84dde596699ffc5100fec2cf7b0d582450.zip
build: Set TMPDIR for local testing.
This avoids conflicts with the globally installed libguestfs appliance, or lets us build in multiple local directories at the same time without conflicts.
Diffstat (limited to 'ruby/Makefile.am')
-rw-r--r--ruby/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/ruby/Makefile.am b/ruby/Makefile.am
index 7ef27eb1..a2e962d9 100644
--- a/ruby/Makefile.am
+++ b/ruby/Makefile.am
@@ -48,7 +48,8 @@ TESTS = run-bindtests run-ruby-tests
TESTS_ENVIRONMENT = \
LD_LIBRARY_PATH=$(top_builddir)/src/.libs \
- LIBGUESTFS_PATH=$(top_builddir)/appliance
+ LIBGUESTFS_PATH=$(top_builddir)/appliance \
+ TMPDIR=$(top_builddir)
all: $(generator_built)
rake build