summaryrefslogtreecommitdiffstats
path: root/ruby/Makefile.am
diff options
context:
space:
mode:
authorHilko Bengen <bengen@hilluzination.de>2011-12-06 20:42:11 +0100
committerRichard W.M. Jones <rjones@redhat.com>2011-12-06 19:48:31 +0000
commit41a7a68cf33a174ba950aa29951a07c391a16b4d (patch)
treeb1ae2aa8eb8f1e7eb56ddf09134bbc6359468168 /ruby/Makefile.am
parent2353b9d3b867fb19db4e403b49a93674d8b2682c (diff)
downloadlibguestfs-41a7a68cf33a174ba950aa29951a07c391a16b4d.tar.gz
libguestfs-41a7a68cf33a174ba950aa29951a07c391a16b4d.tar.xz
libguestfs-41a7a68cf33a174ba950aa29951a07c391a16b4d.zip
let the user explicitly choose ruby and rake programs
Diffstat (limited to 'ruby/Makefile.am')
-rw-r--r--ruby/Makefile.am11
1 files changed, 6 insertions, 5 deletions
diff --git a/ruby/Makefile.am b/ruby/Makefile.am
index 757855a0..8139140a 100644
--- a/ruby/Makefile.am
+++ b/ruby/Makefile.am
@@ -49,14 +49,15 @@ TESTS = run-bindtests run-ruby-tests
TESTS_ENVIRONMENT = \
LD_LIBRARY_PATH=$(top_builddir)/src/.libs \
LIBGUESTFS_PATH=$(top_builddir)/appliance \
- TMPDIR=$(top_builddir)
+ TMPDIR=$(top_builddir) \
+ RUBY=$(RUBY)
all: $(generator_built)
- rake build
- rake rdoc
+ $(RAKE) build
+ $(RAKE) rdoc
-RUBY_SITELIB := $(shell ruby -rrbconfig -e "puts Config::CONFIG['sitelibdir']")
-RUBY_SITEARCH := $(shell ruby -rrbconfig -e "puts Config::CONFIG['sitearchdir']")
+RUBY_SITELIB := $(shell $(RUBY) -rrbconfig -e "puts Config::CONFIG['sitelibdir']")
+RUBY_SITEARCH := $(shell $(RUBY) -rrbconfig -e "puts Config::CONFIG['sitearchdir']")
install:
$(MKDIR_P) $(DESTDIR)$(RUBY_SITELIB)