summaryrefslogtreecommitdiffstats
path: root/python/Makefile.am
diff options
context:
space:
mode:
authorHilko Bengen <bengen@hilluzination.de>2011-08-22 20:42:08 +0200
committerRichard W.M. Jones <rjones@redhat.com>2011-08-24 12:56:45 +0100
commitd36504e1bbe7d1379b7dd7b97ae2fcb0d78d9a83 (patch)
treeda63a39cb49a22295bef7c8b15a12a66334d9e02 /python/Makefile.am
parent4e196ad9a374ecef8a39af3ef028fc593d3b1a46 (diff)
downloadlibguestfs-d36504e1bbe7d1379b7dd7b97ae2fcb0d78d9a83.tar.gz
libguestfs-d36504e1bbe7d1379b7dd7b97ae2fcb0d78d9a83.tar.xz
libguestfs-d36504e1bbe7d1379b7dd7b97ae2fcb0d78d9a83.zip
python: Don't build static library
Diffstat (limited to 'python/Makefile.am')
-rw-r--r--python/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/python/Makefile.am b/python/Makefile.am
index 58847625..82960d6b 100644
--- a/python/Makefile.am
+++ b/python/Makefile.am
@@ -43,7 +43,7 @@ libguestfsmod_la_SOURCES = guestfs-py.c guestfs-py.h guestfs-py-byhand.c
libguestfsmod_la_CFLAGS = -Wall -I$(PYTHON_INCLUDEDIR) \
-I$(top_srcdir)/src -I$(top_builddir)/src
libguestfsmod_la_LIBADD = $(top_builddir)/src/libguestfs.la
-libguestfsmod_la_LDFLAGS = -avoid-version
+libguestfsmod_la_LDFLAGS = -avoid-version -shared
TESTS_ENVIRONMENT = \
LIBGUESTFS_PATH=$(top_builddir)/appliance \