summaryrefslogtreecommitdiffstats
path: root/ocaml/Makefile.am
diff options
context:
space:
mode:
authorHilko Bengen <bengen@hilluzination.de>2012-01-20 08:44:44 +0100
committerRichard W.M. Jones <rjones@redhat.com>2012-01-20 16:10:14 +0000
commit251c6e994de97d9e87a0ace01144c12366e12c2b (patch)
treece7f06514ae42cbda62e6114018f0296b1d7caf2 /ocaml/Makefile.am
parent762d1bbda18ffd6c16980009946549384bb95526 (diff)
downloadlibguestfs-251c6e994de97d9e87a0ace01144c12366e12c2b.tar.gz
libguestfs-251c6e994de97d9e87a0ace01144c12366e12c2b.tar.xz
libguestfs-251c6e994de97d9e87a0ace01144c12366e12c2b.zip
Fixed out-of-tree compilation of OCaml code after .depend files removal
Diffstat (limited to 'ocaml/Makefile.am')
-rw-r--r--ocaml/Makefile.am9
1 files changed, 5 insertions, 4 deletions
diff --git a/ocaml/Makefile.am b/ocaml/Makefile.am
index 35cba466..fbeefc94 100644
--- a/ocaml/Makefile.am
+++ b/ocaml/Makefile.am
@@ -139,12 +139,13 @@ t/%.cmx: t/%.ml mlguestfs.cmxa
depend: .depend
-.depend: $(wildcard *.mli) $(wildcard *.ml)
+.depend: $(wildcard $(abs_srcdir)/*.mli) $(wildcard $(abs_srcdir)/*.ml)
rm -f $@ $@-t
- $(OCAMLFIND) ocamldep $^ | \
- $(SED) -e 's/ *$$//' | \
+ $(OCAMLFIND) ocamldep -I ../ocaml -I $(abs_srcdir) $^ | \
+ $(SED) 's/ *$$//' | \
$(SED) -e :a -e '/ *\\$$/N; s/ *\\\n */ /; ta' | \
- LANG=C sort > $@-t
+ $(SED) -e 's,$(abs_srcdir)/,$(builddir)/,g' | \
+ sort > $@-t
mv $@-t $@
-include .depend