summaryrefslogtreecommitdiffstats
path: root/lua/Makefile.am
diff options
context:
space:
mode:
authorRichard W.M. Jones <rjones@redhat.com>2012-11-19 13:00:52 +0000
committerRichard W.M. Jones <rjones@redhat.com>2012-11-19 14:01:40 +0000
commitf77ddb9e114e560724d6548499047ae6894ab59c (patch)
tree6341c27ca32fb5e1262f1263974991a1d6357b22 /lua/Makefile.am
parentd14557d434de5cb1c9754ae0f3e8e820e0a46694 (diff)
downloadlibguestfs-f77ddb9e114e560724d6548499047ae6894ab59c.tar.gz
libguestfs-f77ddb9e114e560724d6548499047ae6894ab59c.tar.xz
libguestfs-f77ddb9e114e560724d6548499047ae6894ab59c.zip
lua: Various fixes and enhancements:
- add support for events (with test) - test progress messages - update documentation to describe events - refactor handle closing code - refactor error code - use 'assert' in test code instead of 'if ... then error end'
Diffstat (limited to 'lua/Makefile.am')
-rw-r--r--lua/Makefile.am10
1 files changed, 7 insertions, 3 deletions
diff --git a/lua/Makefile.am b/lua/Makefile.am
index e2daceee..7fff50b8 100644
--- a/lua/Makefile.am
+++ b/lua/Makefile.am
@@ -55,12 +55,14 @@ TESTS = \
tests/025-create-flags.lua \
tests/027-create-multiple.lua \
tests/030-config.lua \
- tests/070-optargs.lua
+ tests/070-optargs.lua \
+ tests/400-events.lua
if ENABLE_APPLIANCE
TESTS += \
tests/050-lvcreate.lua \
- tests/060-readdir.lua
+ tests/060-readdir.lua \
+ tests/400-progress.lua
endif
EXTRA_DIST += \
@@ -71,7 +73,9 @@ EXTRA_DIST += \
tests/030-config.lua \
tests/050-lvcreate.lua \
tests/060-readdir.lua \
- tests/070-optargs.lua
+ tests/070-optargs.lua \
+ tests/400-events.lua \
+ tests/400-progress.lua
# Custom install rule.
install-data-hook: