summaryrefslogtreecommitdiffstats
path: root/lua/Makefile.am
diff options
context:
space:
mode:
authorRichard W.M. Jones <rjones@redhat.com>2012-11-20 13:56:06 +0000
committerRichard W.M. Jones <rjones@redhat.com>2012-11-20 14:11:47 +0000
commit7f1f7dd44f4b85c1ce027b2ed194d388518ff452 (patch)
treeebe5c95addfcbefdb0361a988f7ece455a7d67aa /lua/Makefile.am
parentb19f007bd2449f635780078e61a174f19838b32d (diff)
downloadlibguestfs-7f1f7dd44f4b85c1ce027b2ed194d388518ff452.tar.gz
libguestfs-7f1f7dd44f4b85c1ce027b2ed194d388518ff452.tar.xz
libguestfs-7f1f7dd44f4b85c1ce027b2ed194d388518ff452.zip
lua: Add bindtests.
Diffstat (limited to 'lua/Makefile.am')
-rw-r--r--lua/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/lua/Makefile.am b/lua/Makefile.am
index abdc4f02..8cc5930d 100644
--- a/lua/Makefile.am
+++ b/lua/Makefile.am
@@ -20,10 +20,12 @@ include $(top_srcdir)/subdir-rules.mk
lualibdir = $(libdir)/lua/$(LUA_VERSION)
generator_built = \
+ bindtests.lua \
lua-guestfs.c
EXTRA_DIST = \
- $(generator_built)
+ $(generator_built) \
+ run-bindtests
CLEANFILES = *~ guestfs.so
@@ -50,6 +52,7 @@ guestfs.so: libluaguestfs.la
# Tests.
TESTS_ENVIRONMENT = $(top_builddir)/run --test
TESTS = \
+ run-bindtests \
tests/010-load.lua \
tests/015-globals.lua \
tests/020-create.lua \